setting colors in editor - Post ID...

User 2981014 Photo


Registered User
3 posts

Simple query -- almost embarrassed to ask it. Trying to set different colors in the editor, via Tools-Preferences-Customization-Modify Highlighting. I set all lines that have been "commented out" to green. And that works for an html file. But has no impact on a .js file, where I have large amount of text I need (for the moment) to "comment out", in green. But Modify Highlighting seems to apply (in my project) only to the html page. Can't find an option to make it apply to .js files.
User 122279 Photo


Senior Advisor
14,093 posts
Online Now

If you leave the HTML/PHP Documents open and then go to Modify Highlighting, scroll down a bit and you will also see some options for js.
Ha en riktig god dag!
Inger, Norway
This site was made before we were able to create components through the app:
Component sharing for RFF, RBB, RSD and SD: https://eikweb.com/sharing/
My work in progress right now:
Components for the same as above + HTML Editor: https://mock-up.coffeecup.com


User 2981014 Photo


Registered User
3 posts

I can't make any sense out of your reply. You write: "If you leave the HTML/PHP Documents open and then go to Modify Highlighting..." What do you mean by " leave the HTML Documents open"? The only way (that I can see) to get to Modify Highlighting is to have/leave the editor (which I would never call "Documents") open -- else the whole thing vanishes! So I do that, get to Modify Highlighting, select comments and the color I want, note the little box that seems to imply this selection will apply to html and js files, click ok -- and nothing happens to the comments in the js files. Though it did change the comments in associated html files, as desired. How can I make that happen in js files?
User 379556 Photo


Registered User
1,333 posts

When one goes to Customization, there is a drop-down box which initially shows 'HTML/PHP Documents'. The request to leave that open means simply not changing to one of the other possible selections in that drop-down list, as that is the correct section also for modifying the highlighting, fonts etc. for the editing of .js files.

If it seems not to be working as it should for .js files, and in the unlikely event that it hasn't already been done, I would be inclined to check that, after making the changes wished for, OK is clicked on the Highlighting panel and then on the Preferences panel. My experience is that such changes are effected on that second click.

If that doesn't do the trick, I would request the help of the CoffeeCup team at https://www.coffeecup.com/help/myroom/ .

Frank

Have something to add? We’d love to hear it!
You must have an account to participate. Please Sign In Here, then join the conversation.