I would like to separate the utility classes of the framework from my Type classes ...
I fully agree with Twinstream's suggestion. It led me to consider that perhaps other modifications could be made to simplify the working and box names regarding classes.
1. Adopting Twinstream's suggestion could lead to reconsideration of box names, as Type Class seems oddly as though this was something to do with the Type selector.
I suggest that there be the following groups for classes -
(a) Layout Classes,
(b) Framework Classes, and
(c) User Classes (instead of the current Type Class) .
2. Rather than having individually to disable each of the other classes when adding a new class, I suggest that in the User Classes there be the ability to right-click on a class name and choose either
(a) Disable Other User Classes, or
(b) Enable All User Classes.