A few questions on Shopping Cart...

User 2289828 Photo


Registered User
6 posts

:D Thanks, I knew it was something simple and I was trying to make it really hard!
User 31219 Photo


Registered User
58 posts

I had a good working shop using version 3.9.4359 but now my hosting provider requires me to have Shopping Cart Pro use PHP8.1 or higher. Where is the upgrade for this program? I have spent hours searching for an upgrade and trying to get something to work without any luck. All of a sudden, I am place with the decision to delete the shop from the internet leaving me with a huge amount of stock. Looking for some help with this issue.
Cheers and Happy New Year
Robert Marks (Bob)
User 2699991 Photo


Registered User
4,734 posts
Online Now

Bob wrote:
I had a good working shop using version 3.9.4359 but now my hosting provider requires me to have Shopping Cart Pro use PHP8.1 or higher. Where is the upgrade for this program? I have spent hours searching for an upgrade and trying to get something to work without any luck. All of a sudden, I am place with the decision to delete the shop from the internet leaving me with a huge amount of stock. Looking for some help with this issue.
Cheers and Happy New Year
Robert Marks (Bob)


Shopping cart creator has been discontinued for sometime now, no upgrades/updates
Mastering The Understanding With Hands-On Learning
NEW TO "COFFEECUP SITE DESIGNER" FOUNDATION 6 FRAMEWORK?
STUCK ON SOMETHING?

LEARNING & UNDERSTANDING "THE HOW TO"? THE WHY'S & THE WHEREFORE'S?
WITH WAYAN'S STEP BY STEP TUTORIALS
Contact Me For One To One Assistance
https://mawarputih.coffeecup.com/forms/prove-human/
User 463058 Photo


Ambassador
1,070 posts

Maybe you can find a hosting service that will let you continue with php 7?
User 379556 Photo


Registered User
1,520 posts

I fed the the following question into Windows Co-pilot: 'Which hosting services continue to use PHP7?' The following response was given.

"PHP7 is a version of the PHP programming language that was released in 2015 and reached its end of life in 2022. This means that it is no longer supported by the PHP developers and does not receive any security updates or bug fixes. However, some hosting services still offer PHP7 as an option for their customers, either for compatibility reasons or as a paid service.

According to my web search, some of the hosting services that continue to use PHP7 are:

WP Engine, which offers extended security support for PHP 7.4 until 2024 for all its customers 1

Fasthosts, which provides PHP extended support as an additional service for its customers who need to run legacy applications 2

Hostinger, which supports the latest PHP releases, including 7.4, 8.0, and 8.1, and allows customers to switch between versions using its control panel 3

A2 Hosting, which also supports the latest PHP versions, including 7.1-7.4 and 8.0-8.1, and offers a developer-friendly environment 4

However, using an outdated version of PHP can pose security risks and performance issues, so it is recommended to upgrade to the latest version whenever possible. Some hosting services, such as SiteGround, have already moved their customers to PHP 7.4 or higher and discontinued some old versions 5

Learn more
1 wpengine.com
2 help.fasthosts.co.uk
3 websiteplanet.com
4 bitcatcha.com
5 siteground.com"

Frank

Have something to add? We’d love to hear it!
You must have an account to participate. Please Sign In Here, then join the conversation.