Problem with Library Items

User 1987354 Photo


Registered User
28 posts

I installed new version on a new computer; opened my website; no library items present, no custom snippets. Why do these not come in when the site is opened. Had to import the library items from a backup of the "Library" folder from other computer and other version of editor. Now I have to recreate or copy from other computer all the custom snippets! That's not making me happy!
Also, a friend did the same thing, except when she imported her library items they won't update the pages correctly. It shows an error and the path to the library is all messed up. And on one of the items, the imported lbi file recreated an entire page of code within the lbi file!!! This has happened before and REALLY F*#!@% EVERYTHING UP.
Any comments or help as to why this happens. Also, I found that the Library folder is separate from the site folder and if I hadn't found that by accident, I would never have known where to find the library items. I assumed (silly me) that they are contained within the site document, but they are not, as is evident by the fact that they don't transfer with the site to the new computer.
User 122279 Photo


Senior Advisor
13,267 posts
Online Now

Linda, your questions should better be raised with the CC technichians, this is a user-to-user forum. Submit a support ticket and let them answer you.

To me it seems logical that there are no snippets or library items contained in the programme itself, when first installed on a new machine, but I also would have thought that as soon as you open the project file of your website, they should be included.
Ha en riktig god dag!
Inger, Norway
My new honey site, built with RFF: https://eikweb.com/horgenhonning/
Component sharing for RFF, RBB, RSD and SD: https://eikweb.com/sharing/


User 2287960 Photo


Ambassador
546 posts

From experience, you have to add them back in.
Easy if you know where they are stored but can be a problem if you do not.
You have to work out what you added after initial install.
I now always back these details up as you will now.
Keith
User 2808717 Photo


Registered User
19 posts

Anyone else having problems with library items not working properly? When I insert into a page it duplicates a lot of code that was already on the page. Don't tell me to enter a support ticket...they say I'm doing something wrong, which I'm not has I have been using it fine for 4 years.

Edited by Inger:
I copied your other post in here and will delete the other thread, so that you don't have to look for answers in two places.
Christy Stevens wrote:
Lately when I insert a Library file into my html it total goes berserk and I get all kinds of repeated code that I already had in the page. For example, I made a change to footer library file and when I inserted it into the page I was working on, the header and several lines of text showed up three times in a row in my code. The Library files have become a total mess. What's up? I've reinstalled Editor and still doing it. I know what I'm doing so it's not me...this become a recent problem. Anyone else having trouble with inserting the Library files?

Please don't tell me to open a ticket.
User 2943767 Photo


Registered User
3 posts

I also have the Library problem of Christy Stevens.
When doing Library>Update Library Items>Update Project Pages
then: sometimes it works as it should
but: sometimes not only the code from the .tbi file is inserted, but also other code from other files, seemingly randomly. I then have to remove it manually from all pages - a tedious work ...
Does anyone have a solution?
User 122279 Photo


Senior Advisor
13,267 posts
Online Now

I have reported your problems to the CC staff. Hopefully you will get some advice. All I can say is, that I don't have any problems with the library files.
Ha en riktig god dag!
Inger, Norway
My new honey site, built with RFF: https://eikweb.com/horgenhonning/
Component sharing for RFF, RBB, RSD and SD: https://eikweb.com/sharing/


User 399746 Photo


Sales & Support Manager
383 posts

Hey there!

We will be happy to investigate! Can you please open a support ticket within your account. With you ticket can you please zip up one or more of the library files that are doing this and send them to us?
Learn the essentials with these tips on Site Designer. You'll be making epic, code-free responsive sites like a boss.
User 122279 Photo


Senior Advisor
13,267 posts
Online Now

Michael, Christy and any others who have problems with the library files. Rumor has it, that there is a new build of the HTML Editor on it's way, and they are attacking something in the library functions. I can't guarantee that this will fix your problem, but try to use the library only without any preview open in the app. The preview cannot update itself as fast as needed, apparently, and hence the 'wild' code.
It would actually be very good if you could test this and then report back. :)
Ha en riktig god dag!
Inger, Norway
My new honey site, built with RFF: https://eikweb.com/horgenhonning/
Component sharing for RFF, RBB, RSD and SD: https://eikweb.com/sharing/


User 2943767 Photo


Registered User
3 posts

Inger, Suzanne, thanks for the fast helpful response!
1. Yes, so far I used the Update Library function only with the library preview window open. I shall try to close it and will report in this thread what happened. (it may take a few days)
2. I noticed that when the library problem occurs, then unwanted fragments of code from open pages (like index.html) were copied into the library code. Does this info help?
3. I shall be pleased to try out the announced new build. If it solves the problem, then there would be no need to get a support ticket, right?
User 122279 Photo


Senior Advisor
13,267 posts
Online Now

Hi, thanks so far for your feed-back. I'm not able to reply to your 2nd question, as I have only seen a list of suggested fixes, and also heard that there is more to come.

Mind you, I'm not a CoffeeCup staff member, I'm just a user as yourself, although I've been here for something like a generation... :lol: I'm not able to predict any release date of the new version. But if you post your results here, I'll post what I'm able to pick up :)
Ha en riktig god dag!
Inger, Norway
My new honey site, built with RFF: https://eikweb.com/horgenhonning/
Component sharing for RFF, RBB, RSD and SD: https://eikweb.com/sharing/



Have something to add? We’d love to hear it!
You must have an account to participate. Please Sign In Here, then join the conversation.