Suggestions for CoffeeCup Direct FTP...

User 2037337 Photo


Trial User
1 post

Just installed Direct FTP.
Good program, but the next two features are strongly needed:

1) Log tab with communication between server and client, e.g.

Command:> [26.12.2009 23:01:45] REST 0
[26.12.2009 23:01:45] 350 Restarting at 0
Command:> [26.12.2009 23:01:45] PASV
[26.12.2009 23:01:45] 227 Entering Passive Mode
Command:> [26.12.2009 23:01:45] LIST

This should be unclosable tab with highlighting successful and failed requests. When you click right window with remote server contents, this tab should automatically become over other tabs.

2) Add UTF-8 support, and ability to convert text encoding (e.g. ANSI <-> UTF) of the file in editor on-the-fly.

Thus you'll get FTP client better then CuteFTP.
And then I'll buy it.
User 312454 Photo


Registered User
21 posts

Here is a feature that I would love.

If I had the ability to queue up some ftp jobs with all of the parameters set, like source, destination, overwrite, etc and then set a time and date for it to automatically kickoff and perform the ftp job. WOW!!!

I can't tell you how great that would be. Every Saturday at Midnight I have to update a site. If I could have all of the files ready to go and the ftp job set up a day or two in advance, DirectFTP could automatically upload at midnight for me.

I'll be happy to beta test this feature whenever your ready. :D
User 147665 Photo


Ambassador
712 posts

people talking about cute ftp being faster.. I would say that filezilla is the fastest.
After using filezilla, I like the server transfer log window.

In direct ftp I would wish for being able to choose the columns on local and remote separately and being able to toggle or choose each column. I like the details view, but would also like to choose which ones show.
Some people would like to toggle the splash graphic at program start if you start the program a lot of times(like I do).

User 180142 Photo


Ambassador
1,878 posts

I just used Direct FTP after beta testing the HTML Editor which I had no problems with.

HOWEVER, I do have a slight issue with Direct FTP. This is the first time I used it since the new release. When I went to upload the files after locating them in the HTML Editor, I made several attempts to highlight and drag the three files to my server and kept getting thrown into My Documents.

This puzzled me and not to mention frustrated me. Somehow I managed to get my files uploaded.

I did finally manage to figure out I needed to have the list of files instead of details in the FTP Program.

However, would a newbie think to figure this out? If I hadn't been experienced with this, I would have definitely given up.

I tried holding ctrl to choose the 3 files which kept throwing me into My Documents.
User 38401 Photo


Registered User
10,951 posts

I'm trying to follow what you mean here Sue, but I'm not quite grasping what you're saying. I have always had the files shown in detail mode, not sure if that's what you even mean hehe. I just drag the files from one side to the other and it's all good to go. Maybe a screenshot to show what you mean on this would help.
User 2423092 Photo


Guest
634 posts

I know what you mean. The way the controls used to build this application work are different than Windows. For example, no right-click ability in certain views unless you left click first and that kind of thing. Programmers sometimes use Windows-based coding components so that functionality is similar and familiar for people to use but programmers sometimes build their own, avoiding the Windows stuff (because not everyone uses Windows after all) which means we have to get used to the new way things are done. Once used to it though, I don't have any issues, but it would be nicer all round (and easier for beginners to 'slip' into using the software) if the functionality was the same as Windows.

Dave.
davethompson.co.nz
User 180142 Photo


Ambassador
1,878 posts

Jo Ann wrote:
I'm trying to follow what you mean here Sue, but I'm not quite grasping what you're saying. I have always had the files shown in detail mode, not sure if that's what you even mean hehe. I just drag the files from one side to the other and it's all good to go. Maybe a screenshot to show what you mean on this would help.


I was attempting to drag 3 files at the same time. Since I just installed the latest version, I had not played around in it until then and everything was squashed in the detail mode. It did not occur to me to expand it all at the time. I was just getting too frustrated to think clearly. Only after I managed to my files uploaded that I changed to the list mode which took a couple moments to figure out.

I was using the ctrl in the squashed mode to choose my 3 files and that kept throwing me into My Documents.

Make any sense now? LOL Guess you should have been there with me..... ;)
User 38401 Photo


Registered User
10,951 posts

hehe yeah it makes sense, but it doesn't make sense that it happened. I drag multiple files using the ctrl key to highlight them all the time, and the Shift key also, I use detail mode always, never use any others in that program and most others unless I need to see an image thumbnail, so that's why I'm confused as to why it's acting like that for you. I didn't have to switch any modes or do anything to it at all to make it work, it worked pretty much right outta the box other than setting up my servers.

I don't have that strange quirk that sends me to other locations I guess is my point. Maybe try reinstalling? Unless I'm still missing the point, because most of it works just like Windows for me. So far the only issue I have is the ctrl-c pasting on the server side of it which opens the read/write properties settings on me. That's it for my end.
User 180142 Photo


Ambassador
1,878 posts

Maybe it is a Windows 7 issue??? Or perhaps it didn't like me at the time? LOL
User 38401 Photo


Registered User
10,951 posts

LOL awwwww now what's not to like about you Sue? Just smack it upside the icon and tell it to get with the program! :P

Seriously though, that could very well be, have you set administrator mode and tried windows xp compatibility at all yet? If not, try those. If so, I would suggest a clean uninstall and reinstall and see if that works. If not, then definitely put in a ticket as it sounds like something is conflicting somewhere and we could talk for weeks to find that out hehe.

Have something to add? We’d love to hear it!
You must have an account to participate. Please Sign In Here, then join the conversation.