Website search - Post ID 139219

User 38401 Photo


Senior Advisor
10,951 posts

I also don't see any doctype line either, could that make a difference guys?
User 2135058 Photo


Guest
8 posts

Hi Jo.

Thanks for the tips. I did have doc types on the original pages but removed them when I couldn't get the search to work. Have put them back in now, and changed the <p> tags to <div> but still can't get it to work.

Cheers,
Lance.

PS: Think my head is starting to hurt ...:)
User 126492 Photo


Ambassador
1,507 posts

Try these headers, just in case it needs the <meta http-equiv

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" dir="ltr" lang="en">
<head>
<title>Your title</title>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />


I is not reading the first page correctly, I think there is an error in the search.txt file,
<content>??&lt; h t m l > this part should not be there ??&lt; h t m l >

when you have done the scan, what do you get under the page it finds, is it like in the attached image.




Attachments:
Jim
---------------------------
User 2135058 Photo


Guest
8 posts

Hi Jim,

Yeah, that's exactly what I get under the page it finds.

Have replaced the headers though with your version and re-run the Build Search function, but it still looks like its only finding the first page and the not finding any search results. Thanks for trying to help.

Lance.
User 126492 Photo


Ambassador
1,507 posts

Strange.

I copied your pages and uploaded them to some free webspace I have, then I ran the SiteSearch scan and you can see what I get in the attached image, I can't let you see the actual search working because the freespace doesn't allow php files, but at least it follow the links.

It could be your server that is the problem.
Attachments:
Jim
---------------------------
User 2135058 Photo


Guest
8 posts

Thanks Jim.

At least I know its not the software that's the problem but the server.

Do you know if there's a full list of technical requirements that I can pass on to my webhost to look at at maybe?

I spoke to them again last night, and other than confirming the server is running UNIX and PHP5 they said if they saw the full requirements they might be able to suggest something.

Wondering if I should maybe swtich to a Windows server? Hmmmm.

Thanks,
Lance.
User 126492 Photo


Ambassador
1,507 posts

The only requirements that I know of are Server Requirements: PHP 4.3, but doing the scan does not use php as I have shown running it on my freespace, there is definateley something not right though.
The search.txt that is produced is not formatted correctly, where as the one I got from the scan is perfect.

This is part of yours:-
---------------
<indexed>Sep 26, 2010</indexed>
<title></title>
<meta_keys></meta_keys>
<meta_desc></meta_desc>
<user_keys></user_keys>
<user_weight>1</user_weight>
<content>??&lt; ! D O C T Y P E h t m l P U B L I C " - / / W 3 C / / D T D X H T M L 1 . 0 T r a n s i t i o n a l / / E N " " h t t p : / / w w w . w 3 . o r g / T R / x h t m l 1 / D T D / x h t m l 1 - t r a n s i t i o n a l . d t d " > < h t m l x m l n s = " h t t p : / / w w w . w 3 . o r g / 1 9 9 9 / x h t m l " d i r = " l t r " l a n g = " e n " > < h e a d > < t i t l e > N e t w o r k F i r s t T V | F r o n t p a g e < / t i t l e >
----------------------------------
This is part of mine from your pages:-

<indexed>Sep 27, 2010</indexed>
<title> Network First TV | Frontpage </title>
<meta_keys>Illustrated survey of the UK broadcast media sector focusing on television presentation, programme promotion and channel branding including visual identity, corporate design and motion graphics.Network First TV, NetworkFirstTV. Network 1st TV, Network1stTV, Television presentation, promotion, branding, visual identity, design, motion graphics, logos idents, continuity, trailers, promos, adverts, symbols.</meta_keys>
<meta_desc></meta_desc>
<user_keys></user_keys>
<user_weight>1</user_weight>
<content>Search Software Test This takes you to Page 1 This takes you to Page 2 This takes you to Page 3 </content>
-------------------------

The difference is easy to see.

I wouldn't think about changing to Windows server, if it is with the same host things could still be the same.

You may know more when you get a response from the support ticket that Scott setup for you.
Jim
---------------------------
User 2135058 Photo


Guest
8 posts

Ok.

Thanks Jim. Will wait to hear back on the support ticket.

Cheers,
Lance.

Have something to add? We’d love to hear it!
You must have an account to participate. Please Sign In Here, then join the conversation.