Centering a gallery

User 188640 Photo


Registered User
758 posts

I could use a little css help with centering a gallery.

I know I must not be using the correct info to center inside an html element which is inside a container.

Here's the link to the page on my test domain: http://mytestblog.net/gallery/

Here's a link to the RSD project file: http://mytestblog.net/gallery/ FancyboxGallery.rsd

I've had a few rough days in a row and would just like to get this fixed. I have 9 of these to build and I know this is something that is really simple.

Thanks for any help.
A Rose is Just a Weed in a Corn Patch!
User 188640 Photo


Registered User
758 posts

OK, it just keeps getting better today. I'll try the link to the project file AGAIN!

http://mytestblog.net/gallery/FancyboxGallery.rsd
A Rose is Just a Weed in a Corn Patch!
User 2699991 Photo


Registered User
2,508 posts
Online Now

Ernie Hodge wrote:
OK, it just keeps getting better today. I'll try the link to the project file AGAIN!

http://mytestblog.net/gallery/FancyboxGallery.rsd


Ernie,

Select the container that holds the html element

Go to position ,,,, display flex
Go to Justify.....select Center

Hope that's what you are looking for, and that helps improve your day.

Wayan
The Help You Need: When You Need It The Most
User 188640 Photo


Registered User
758 posts

Wayan,

I knew there had to be an easy fix. Thank you for your help. My day just got a lot better. :D
A Rose is Just a Weed in a Corn Patch!
User 188640 Photo


Registered User
758 posts

I have this site all ready to be uploaded after a rebuild in RSD and I have one page being a PITA.

I was having trouble getting the map centered and have tried every combination with flex and css but I'm stumped.
Here's a link to the page on my test site: http://mytestblog.net/location.html

Here's what happens when I try and auto margin the html element: http://mytestblog.net/images/2016-08-13_18-53-22.png

I'm calling it a night as I have about an eight hour road trip tomorrow morning. I'll check in after I get back and thanks for any help.
A Rose is Just a Weed in a Corn Patch!
User 188640 Photo


Registered User
758 posts

OK, update. I rebuilt the entire page and now it's working like it's supposed to work except the mobile menu button doesn't show up at the lower breakpoints. The main menu is OK where it's supposed to be.

Link to page: http://mytestblog.net/location.html

Project file: http://mytestblog.net/images/PanaVistaLodge.rsd

Thanks for any help.

A Rose is Just a Weed in a Corn Patch!
User 379556 Photo


Registered User
933 posts

I don't know the answer, but it looks as though the disappearance occurs at exactly 750px width. The RSD file has no breakpoint at that width. That makes me wonder whether the matter may relate to the Menu Builder file (which perhaps has a breakpoint at 750px) rather than the RSD file.

Frank
User 188640 Photo


Registered User
758 posts

Frank,

I hadn't even thought about that since all the other pages are working correctly. I'll reenter all the menu code and see if that fixes the issue. Thanks.
A Rose is Just a Weed in a Corn Patch!
User 188640 Photo


Registered User
758 posts

Frank,

I guess the code was corrupt because when I pasted the new code into the element it works fine. It isn't responsive all the way down but I can work on that. Thanks again for pointing me in the right direction. You know, to close to the trees. :D
A Rose is Just a Weed in a Corn Patch!
User 188640 Photo


Registered User
758 posts

OK, I finally found the article on adding a responsive map to RSD. Everything works great but I need to add some padding to each side of the map.

I've added padding to the html element and then the container and no joy. Where exactly do we add padding so when the map is down to mobile size users can scroll past the map?
A Rose is Just a Weed in a Corn Patch!

Have something to add? We’d love to hear it!
You must have an account to participate. Please Sign In Here, then join the conversation.