Date and time in Web Form Builder -...

User 187934 Photo


Senior Advisor
20,007 posts

I see in the fb file your time select says Choose one for the option. Are you manually changing that after export? It should be the same as the validation.
"time":{"label":"Start Time","fieldtype":"dropdown","values":["Choose Date First"]},

Here's what I get after changing option text and exporting.
"time":{"label":"Start Time","fieldtype":"dropdown","required":true,"values":[""]
I can't hear what I'm looking at.
It's easy to overlook something you're not looking for.

This is a site I built for my work.(RSD)
http://esmansgreenhouse.com
This is a site I built for use in my job.(HTML Editor)
https://pestlogbook.com
This is my personal site used for testing and as an easy way to share photos.(RLM imported to RSD)
https://ericrohloff.com
User 2982483 Photo


Registered User
43 posts

OK I'm now getting a 'HTTP ERROR 500' response on submit.
User 187934 Photo


Senior Advisor
20,007 posts

Try undoing this and returning it to original state.
Eric Rohloff wrote:
Are you using an iframe to show your form or going directly to the form page?
Give this a try.
Line 62 of the formpage.cls.php page
It's in the directory myformname/fbapp/php/formpage.cls.php
Change this
$filename = $this->name . '.html';

to
$filename = $this->name . '.php';

I can't hear what I'm looking at.
It's easy to overlook something you're not looking for.

This is a site I built for my work.(RSD)
http://esmansgreenhouse.com
This is a site I built for use in my job.(HTML Editor)
https://pestlogbook.com
This is my personal site used for testing and as an easy way to share photos.(RLM imported to RSD)
https://ericrohloff.com
User 2982483 Photo


Registered User
43 posts

No I don't use iframe.
Yeap that's all changed html to php. I actually forgot about that when a re-uploaded the form.

Now we're back to this error:

"prepare("SELECT date(date) a FROM $dbtableblock WHERE time ='' ORDER BY date DESC"); $sql->execute(); $results = $sql; $results = array();; $sql->bindColumn('a',$a); while($row = $sql->fetch()) { $results = array_merge($results, explode(',', date('Y-n-j',strtotime($a)))); } ?>"

and under that is the form and it says under 'Choose Date First', in red "Start Time" doesn't have a valid value."

I've actually moved the form as it was getting to far down in the folder structure for my liking.
See here: https://freesite.today/booking/booking.php
User 187934 Photo


Senior Advisor
20,007 posts

I would delete everything in the directory and reupload the structure. It looks like an old form is what is showing after submit.
https://freesite.today/booking.php
If you look at the source code you can see the the last ?> in the php top code has been changed.
view-source:https://freesite.today/booking.php
I can't hear what I'm looking at.
It's easy to overlook something you're not looking for.

This is a site I built for my work.(RSD)
http://esmansgreenhouse.com
This is a site I built for use in my job.(HTML Editor)
https://pestlogbook.com
This is my personal site used for testing and as an easy way to share photos.(RLM imported to RSD)
https://ericrohloff.com
User 2982483 Photo


Registered User
43 posts

I added a <p> tag with 'this is a test' in it and it's the same form after submission?
https://freesite.today/booking/booking.php

I did use the latest saved version when I moved it.
User 187934 Photo


Senior Advisor
20,007 posts

What do you have this set at?
Eric Rohloff wrote:
Are you using an iframe to show your form or going directly to the form page?
Give this a try.
Line 62 of the formpage.cls.php page
It's in the directory myformname/fbapp/php/formpage.cls.php
Change this
$filename = $this->name . '.html';

to
$filename = $this->name . '.php';

I can't hear what I'm looking at.
It's easy to overlook something you're not looking for.

This is a site I built for my work.(RSD)
http://esmansgreenhouse.com
This is a site I built for use in my job.(HTML Editor)
https://pestlogbook.com
This is my personal site used for testing and as an easy way to share photos.(RLM imported to RSD)
https://ericrohloff.com
User 2982483 Photo


Registered User
43 posts

$filename = $this->name . '.php';
User 187934 Photo


Senior Advisor
20,007 posts

I'm testing the form on my host. I'm close but it appears that php 8 is not playing well with the Form Builder. I think CC is working on an update to help out some of the issues with v8 and the scripts.
I uploaded the form put a regular date field in and filled in a few time options for testing and the form still hangs up. It's not my scripts causing the issue.
Sorry we're at a stand still until the Form Builder is updated.
It's posting to the database in each form version I tried. It's the Cart scripts with Paypal that's breaking it now.
What version of PHP is on your host?
If you put a regular date field and fill in a few options and upload your form does it work then?
I would be curious if it works before alteration.
I can't hear what I'm looking at.
It's easy to overlook something you're not looking for.

This is a site I built for my work.(RSD)
http://esmansgreenhouse.com
This is a site I built for use in my job.(HTML Editor)
https://pestlogbook.com
This is my personal site used for testing and as an easy way to share photos.(RLM imported to RSD)
https://ericrohloff.com
User 2982483 Photo


Registered User
43 posts

PHP 7.4. I'm wondering whether I can bypass the cart and use an actual Paypal button, what do you think? as this was working well even though it was hanging up on the integrated Paypal button.

Have something to add? We’d love to hear it!
You must have an account to participate. Please Sign In Here, then join the conversation.