Question marks on phone - Post ID 301451

User 458539 Photo


Registered User
1,597 posts

I'm sure there is any easy fix but I can't figure out why my phone numbers post with ?'s at the beginning and the end?

(Footer and when it goes to mobile)
http://poperemodeling.com/index.html
User 458539 Photo


Registered User
1,597 posts

btw I used element - href tel:1234561234
User 122279 Photo


Senior Advisor
14,482 posts

The source code is this: <a class="link-text footer-phone" href="tel:7134437309" title=""><span>?</span>713.443.7309<span>?</span></a>

It seems you have two redundant span tags, each with a question mark in them. I don't know what you did to get this, but you need to get rid of them.
Ha en riktig god dag!
Inger, Norway

My work in progress:
Components for Site Designer and the HTML Editor: https://mock-up.coffeecup.com


User 2699991 Photo


Registered User
4,901 posts
Online Now


Enter the link like this
tel:123 4567 20123 204567

make sure you have the 'Automatic Encoding' thingy just below it selected

be aware tough that on desktops it isn't actually a good idea to have a telephone number displays as a link, most people don't have any app installed that can call numbers, (mobile devices no problem) so what you should really do is have 2 buttons (links) 1 for mobile devices that is displayed upto larger devices, then hidden,
the other one hidden for small devices, and displays for larger devices.

That is a much cleaner and nicer way for your clients visitors,

Mastering The Understanding With Hands-On Learning
NEW TO "COFFEECUP SITE DESIGNER" FOUNDATION 6 FRAMEWORK?
STUCK ON SOMETHING?

LEARNING & UNDERSTANDING "THE HOW TO"? THE WHY'S & THE WHEREFORE'S?
WITH WAYAN'S STEP BY STEP TUTORIALS
Contact Me For One To One Assistance
https://alphathemes.coffeecup.com/forms … uman-lina/

Have something to add? We’d love to hear it!
You must have an account to participate. Please Sign In Here, then join the conversation.