Flex not behaving nicely.

User 2695940 Photo


Registered User
99 posts
Online Now

I've noticed that Flex is not working the way I expected it to lately. I'm not sure if this was from a recent update but I can't recall ever having this issue.

I have a container with 3 elements in it. An html and 2 picture elements. When I set the container to Flex and set it to Column on the smallest screen size, then go to the medium screen size (I'm using Foundation) and change it to Row all is fine until I go back to the small screen size and it is set to Row instead of Column as before. I'm starting with the mobil screen size first when I do this but just as a test I have tried it from both directions. Small screen to large and vice versa.

I've attached a small rsd file as an example. Can someone tell me if they see the same results with this file?

Thanks heaps!
John
Attachments:
John Ferguson
Website Design and Development
www.jf1.co
User 2699991 Photo


Registered User
3,124 posts
Online Now

Hey John
I too have had some issues with flexing not consistently so haven't been able to replicate it to send to cc for investigation.
I will look at your file shortly as I an on the way to the office now

The Help You Need: When You Need It The Most
Website Design & Development
Website Renovations
Wayans' Theme Park
Watch Listen & Learn Video Tutorials
User 2699991 Photo


Registered User
3,124 posts
Online Now

Well John The problem for you is that you still have all the breakpoints disabled (which is now the default for all new projects, so any styling you make is really for the small end, and because breakpoints are sisabled, the style is what you get for all.

All you need to do is to set the toggle breakpoints tab (open the drop down,_ to "Defailut mode" (thats confusing I know and it got me for a while too () think they have been informed to change the menu list) If you look carefully the "disable all breakpoints box is ticked)

but then all you really need do is set that container the
row
wrap
flex start
center
center
then that wil automatically fit the child elements and change them as the widthe gers wider

so you only have the one CSS property all the way up from bottom to top


The Help You Need: When You Need It The Most
Website Design & Development
Website Renovations
Wayans' Theme Park
Watch Listen & Learn Video Tutorials
User 2699991 Photo


Registered User
3,124 posts
Online Now

have sent a file to your mail, with the container set as described below for an example (couldn't sed it via coffee cup for some stupid reason

The Help You Need: When You Need It The Most
Website Design & Development
Website Renovations
Wayans' Theme Park
Watch Listen & Learn Video Tutorials
User 2695940 Photo


Registered User
99 posts
Online Now

Wayan Jaya Space Cadet wrote:
Well John The problem for you is that you still have all the breakpoints disabled (which is now the default for all new projects, so any styling you make is really for the small end, and because breakpoints are sisabled, the style is what you get for all.

All you need to do is to set the toggle breakpoints tab (open the drop down,_ to "Defailut mode" (thats confusing I know and it got me for a while too () think they have been informed to change the menu list) If you look carefully the "disable all breakpoints box is ticked)

but then all you really need do is set that container the
row
wrap
flex start
center
center
then that wil automatically fit the child elements and change them as the widthe gers wider

so you only have the one CSS property all the way up from bottom to top



Thanks heaps Wayan, I thought I was going bonkers there for awhile! Really don't understand how that happened as it was an old file from a previous version but I'll be sure to check on the original file. Off to bed right now but will be back to you in a few hours.

Thanks again!
John Ferguson
Website Design and Development
www.jf1.co
User 2695940 Photo


Registered User
99 posts
Online Now

Had to check it out before heading to bed. You were right, it was set with all waypoints disabled. All good now. Not sure I agree with CC thinking on this being the default mode!

Cheers,
John
John Ferguson
Website Design and Development
www.jf1.co
User 2699991 Photo


Registered User
3,124 posts
Online Now

I think Old (prev version) files are opened as new project files hence the all breakpoints disabled now is the new default mode which unless I am mistaken the cc team still haven't informed us about officially throgh the change.logs, which seems strange to me as it is quite a change really and one which I would have thought deserves a mention in those change logs notices thingy.

The Help You Need: When You Need It The Most
Website Design & Development
Website Renovations
Wayans' Theme Park
Watch Listen & Learn Video Tutorials
User 2695940 Photo


Registered User
99 posts
Online Now

Wayan Jaya Space Cadet wrote:
I think Old (prev version) files are opened as new project files hence the all breakpoints disabled now is the new default mode which unless I am mistaken the cc team still haven't informed us about officially throgh the change.logs, which seems strange to me as it is quite a change really and one which I would have thought deserves a mention in those change logs notices thingy.


I totally agree Wayan, should probably have been mentioned. Guess you can't think of everything.... thanks again for pointing out the problem!
John Ferguson
Website Design and Development
www.jf1.co

Have something to add? We’d love to hear it!
You must have an account to participate. Please Sign In Here, then join the conversation.