Container sequence at different sizes...

User 3144608 Photo


Registered User
22 posts

I'm a newbie, so please be patient. I have a hero container with two containers inside it. In phone size, they appear in the correct sequence, but when I expand the size, the top container moves to the right instead of the bottom container moving to the right. What setting am I missing?
User 2699991 Photo


Registered User
4,901 posts

Brian Proffit wrote:
I'm a newbie, so please be patient. I have a hero container with two containers inside it. In phone size, they appear in the correct sequence, but when I expand the size, the top container moves to the right instead of the bottom container moving to the right. What setting am I missing?


What framework are you using? and the containers? are they the CSS grid based cols or the Framework based cols?
Mastering The Understanding With Hands-On Learning
NEW TO "COFFEECUP SITE DESIGNER" FOUNDATION 6 FRAMEWORK?
STUCK ON SOMETHING?

LEARNING & UNDERSTANDING "THE HOW TO"? THE WHY'S & THE WHEREFORE'S?
WITH WAYAN'S STEP BY STEP TUTORIALS
Contact Me For One To One Assistance
https://alphathemes.coffeecup.com/forms … uman-lina/
User 3144608 Photo


Registered User
22 posts

Wayan Jaya wrote:
What framework are you using? and the containers? are they the CSS grid based cols or the Framework based cols?


It's the free FireFile theme from CoffeeCup, which is BootStrap based, and apparently uses its columns.
User 2699991 Photo


Registered User
4,901 posts

A quick demo

(silent movie because its early morning here and everyone still asleep!!

https://youtu.be/Kdy6SuhJc-M

The parent container is set to Grid Based Layout, simply a matter of reversing the sequence of it's 2 child containers.
Mastering The Understanding With Hands-On Learning
NEW TO "COFFEECUP SITE DESIGNER" FOUNDATION 6 FRAMEWORK?
STUCK ON SOMETHING?

LEARNING & UNDERSTANDING "THE HOW TO"? THE WHY'S & THE WHEREFORE'S?
WITH WAYAN'S STEP BY STEP TUTORIALS
Contact Me For One To One Assistance
https://alphathemes.coffeecup.com/forms … uman-lina/
User 3144608 Photo


Registered User
22 posts

Wow, thank you! I wondered why simply moving the sequence of the two in the Inspector pane didn't work.

I really appreciate you taking the time to help.
User 3144608 Photo


Registered User
22 posts

Except... it isn't the same for me. I'm attaching a screen shot that shows that the two containers are still showing horizontal, even though I've expanded to the larger breakpoint where they're vertical. The captions at the top and left of my grid are different from yours as well.
Attachments:
User 2699991 Photo


Registered User
4,901 posts

Brian Proffit wrote:
Except... it isn't the same for me. I'm attaching a screen shot that shows that the two containers are still showing horizontal, even though I've expanded to the larger breakpoint where they're vertical. The captions at the top and left of my grid are different from yours as well.


You have the containers set to 100% c, they should be set to 1fr each that divides them equally in the parent container
Mastering The Understanding With Hands-On Learning
NEW TO "COFFEECUP SITE DESIGNER" FOUNDATION 6 FRAMEWORK?
STUCK ON SOMETHING?

LEARNING & UNDERSTANDING "THE HOW TO"? THE WHY'S & THE WHEREFORE'S?
WITH WAYAN'S STEP BY STEP TUTORIALS
Contact Me For One To One Assistance
https://alphathemes.coffeecup.com/forms … uman-lina/
User 3144608 Photo


Registered User
22 posts

Wayan Jaya wrote:
You have the containers set to 100% c, they should be set to 1fr each that divides them equally in the parent container


Hmmm, that's a fresh "New from template" untouched, so I guess those aren't the default settings. Thanks, I'll find and fix those settings.
User 2699991 Photo


Registered User
4,901 posts

You also need to make sure that you have selected "default breakpoints" otherwise it will style and do everything as if no breakpoints existed
Mastering The Understanding With Hands-On Learning
NEW TO "COFFEECUP SITE DESIGNER" FOUNDATION 6 FRAMEWORK?
STUCK ON SOMETHING?

LEARNING & UNDERSTANDING "THE HOW TO"? THE WHY'S & THE WHEREFORE'S?
WITH WAYAN'S STEP BY STEP TUTORIALS
Contact Me For One To One Assistance
https://alphathemes.coffeecup.com/forms … uman-lina/
User 3144608 Photo


Registered User
22 posts

Ahhhh, default breakpoints mode was the issue!!! Thanks, I'm in business now!

Have something to add? We’d love to hear it!
You must have an account to participate. Please Sign In Here, then join the conversation.