Can you spot what I can't?

User 122279 Photo


Senior Advisor
12,982 posts

I'm working on an image gallery component for my library. You can see a not yet finished demo here:
http://horgenhonning.net/sharing/sd3-gallery/
And the project file is here:
https://www.dropbox.com/s/l14nu17r6odus … y.zip?dl=0

The problem I don't seem to be able to solve is, when you click on one of the images, you get a larger version, and 7 of them are nicely aligned to the top of the page - except for the 8th image. I can't for the life of me find out why. It seems to happen right after the first blue breakpoint. Anyone?
Ha en riktig god dag!
Inger, Norway
My new honey site, built with RFF: https://eikweb.com/horgenhonning/
Component sharing for RFF, RBB, RSD and SD: https://eikweb.com/sharing/


User 2903050 Photo


Registered User
256 posts

Hi Inger. Looks great from mobile. I will have a look tonight if no one gives you an answer beforehand. Regards Phil
User 244626 Photo


Registered User
776 posts

I do see in the project file inside #img8 container the button link for the close occurs at the very last in the structure. In your other #img's container(s) the button link occurs before the forward-back container and paragraph ?

I used a compare utility.
User 379556 Photo


Registered User
1,020 posts

I think it may be the position of the close button for the reaveal large pic 8. It has somehow got into the forward-back container instead of being immediately after the modal-img.

I have temporarily put a revised .rsd file here, so you can quickly check whether I've identified the problem you mention, and not just spotted something else.

Frank

PS Twinstream's post somehow arrived while I was typing mine, but perhaps my adjusted .rsd file will be useful for checking.
PPS The Chrome browser leaves the background pictures where they were before opening the modal image, whereas other browsers always bring the first image to the top.
User 122279 Photo


Senior Advisor
12,982 posts

Hi guys, thanks so much! :):):) I found the error now that you pointed my nose to it. I had been too busy looking for differences in the css to think of checking anything else.

I had been working on my laptop this morning, and the error was much more noticeable on the laptop that on the destop, where I am now.

I'll see if I get this thing finalized then. ;)
Ha en riktig god dag!
Inger, Norway
My new honey site, built with RFF: https://eikweb.com/horgenhonning/
Component sharing for RFF, RBB, RSD and SD: https://eikweb.com/sharing/



Have something to add? We’d love to hear it!
You must have an account to participate. Please Sign In Here, then join the conversation.