PHP 7.2, 7.3, 7.4 not compatible with...

User 94229 Photo


Registered User
2 posts

Just received notice from my Hosting company that they are upgradiing to PHP 7.4
So far I have used 7.2 for SCCPro no problem.
Noticed that as soon as I changed server to 7.3 I get many errors in SCCPro.
Is there anything that can be done to change this without having to edit these pages every time I create the shopping Cart (usually weekly)?

Errors are:
Warning: Use of undefined constant NOPAGE - assumed 'NOPAGE' (this will throw an Error in a future version of PHP) in config.inc.php on line 70
Warning: session_name(): Cannot change session name when headers already sent in php/page.cls.php on line 135
Warning: session_start(): Cannot start session when headers already sent in php/page.cls.php on line 136
Warning: Use of undefined constant pos - assumed 'pos' (this will throw an Error in a future version of PHP) in page.cls.php on line 374

User 187934 Photo


Senior Advisor
19,683 posts

Hi Rodney,
The pages that need editing may be stock pages that don't actually change every time you export or upload the shop. Maybe you could keep copies of the ones you edit and upload them after you republish your shop.
I can't hear what I'm looking at.
It's easy to overlook something you're not looking for.

This is a site I built for my work.(RSD)
http://esmansgreenhouse.com
This is a site I built for use in my job.(HTML Editor)
https://pestlogbook.com
This is my personal site used for testing and as an easy way to share photos.(RLM imported to RSD)
https://ericrohloff.com

Have something to add? We’d love to hear it!
You must have an account to participate. Please Sign In Here, then join the conversation.