Slideshow not working in SD - Post ID...

User 2879936 Photo


Registered User
36 posts

Hi guys,

So I'm pulling my hair out trying to figure out why my slideshow preview in Responsive Content Slider is perfect, yet when I embed it in my website, the transitions are all choppy and it just looks wonky in general. I saved my slideshow, exported it for embedding, copied and pasted the header info and the HTML info into SD. I then uploaded the slideshow folder into my resources in SD.

The website is: https://www.twinworksboutique.com/

Does the slideshow look choppy to you too? I'm not sure what I'm doing wrong!

Thanks,
Laura
User 2879936 Photo


Registered User
36 posts

It also seems to not even animate on mobile, although the preview in RCS shows that it does. :/
User 122279 Photo


Senior Advisor
13,166 posts
Online Now

Can't help you with RCS, never got the grasp of it myself.

Foundation's own Orbit slideshow works, at all viewports.
Ha en riktig god dag!
Inger, Norway
My new honey site, built with RFF: https://eikweb.com/horgenhonning/
Component sharing for RFF, RBB, RSD and SD: https://eikweb.com/sharing/


User 2879936 Photo


Registered User
36 posts

Thanks for the reply, Inger!

I'm mostly frustrated because I was able to get a different slideshow to work previously, though I had to go through hoops to get it to work, and I honestly don't remember how I did it!

I'll keep messing around to see if I can get it to work!
User 2699991 Photo


Registered User
3,030 posts
Online Now

Laura K wrote:
Thanks for the reply, Inger!

I'm mostly frustrated because I was able to get a different slideshow to work previously, though I had to go through hoops to get it to work, and I honestly don't remember how I did it!

I'll keep messing around to see if I can get it to work!

Orbit Orbit Orbit

RCS is notorious for playing up, it's so fiddly nowadays

Orbit is the thing if you are using the foundation framework,

I can provide a how to video showing how to :D if you with
https://mawarputih.id
The Help You Need: When You Need It The Most
Website Design & Development
Website Renovations
Wayans' Theme Park
Page Ingredients
User 2879936 Photo


Registered User
36 posts

Hi Wayan!

Okay, I will definitely look into it, especially since you’ve both mentioned it! I am interested in your video for sure. :)
User 2699991 Photo


Registered User
3,030 posts
Online Now

Laura K wrote:
Hi Wayan!

Okay, I will definitely look into it, especially since you’ve both mentioned it! I am interested in your video for sure. :)


Ok It Shal Be So :D
https://mawarputih.id
The Help You Need: When You Need It The Most
Website Design & Development
Website Renovations
Wayans' Theme Park
Page Ingredients
User 2879936 Photo


Registered User
36 posts

Okay, I did a LOT of troubleshooting and I finally figured out a method that works for me!

HOW TO INSTALL/EMBED A SLIDESHOW IN SITE DESIGNER WITH RCS:

1. Create your slideshow
2. Do NOT give the Slideshow Container a custom ID*- RCS will automatically generate a slideshow ID (i.e. cc-slideshow-0ee834e9)
3. Do NOT give the Slides custom IDs*- RCS will automatically generate slide IDs
4. Export "For Embedding"
5. Copy and Paste the generated header info into Site Designer and the embed info in your HTML element
6. Open Resources in Site Designer and upload the slideshow folder (i.e. cc-slideshow-0ee834e9) to your root
7. Publish your SD website

NOTE: Every time I needed to modify and re-publish my existing slideshow, I deleted the previously automatically generated ID names for each slide and for the Slideshow Container (this ensured the modified slideshow and slides had new auto-generated IDs). I saved the modified slideshow under a new project name. I then followed steps 4-7.

I also made sure to delete all old slideshow folders from my S-Drive.

I followed this method at least ten times making modifications to one slideshow, and though it was tedious, it worked every single time! I hope this helps someone else who might be having issues as well!

* My issue seemed to stem from using custom IDs. Once I allowed RCS to generate its own IDs, my slideshow magically worked in SD.

User 2699991 Photo


Registered User
3,030 posts
Online Now

Laura K wrote:
Okay, I did a LOT of troubleshooting and I finally figured out a method that works for me!

HOW TO INSTALL/EMBED A SLIDESHOW IN SITE DESIGNER WITH RCS:

1. Create your slideshow
2. Do NOT give the Slideshow Container a custom ID*- RCS will automatically generate a slideshow ID (i.e. cc-slideshow-0ee834e9)
3. Do NOT give the Slides custom IDs*- RCS will automatically generate slide IDs
4. Export "For Embedding"
5. Copy and Paste the generated header info into Site Designer and the embed info in your HTML element
6. Open Resources in Site Designer and upload the slideshow folder (i.e. cc-slideshow-0ee834e9) to your root
7. Publish your SD website

NOTE: Every time I needed to modify and re-publish my existing slideshow, I deleted the previously automatically generated ID names for each slide and for the Slideshow Container (this ensured the modified slideshow and slides had new auto-generated IDs). I saved the modified slideshow under a new project name. I then followed steps 4-7.

I also made sure to delete all old slideshow folders from my S-Drive.

I followed this method at least ten times making modifications to one slideshow, and though it was tedious, it worked every single time! I hope this helps someone else who might be having issues as well!

* My issue seemed to stem from using custom IDs. Once I allowed RCS to generate its own IDs, my slideshow magically worked in SD.


well done no need for the orbit then:D
https://mawarputih.id
The Help You Need: When You Need It The Most
Website Design & Development
Website Renovations
Wayans' Theme Park
Page Ingredients
User 556652 Photo


Registered User
76 posts
Online Now

HOW TO INSTALL/EMBED A SLIDESHOW IN SITE DESIGNER WITH RCS:

1. Create your slideshow
2. Do NOT give the Slideshow Container a custom ID*- RCS will automatically generate a slideshow ID (i.e. cc-slideshow-0ee834e9)
3. Do NOT give the Slides custom IDs*- RCS will automatically generate slide IDs
4. Export "For Embedding"
5. Copy and Paste the generated header info into Site Designer and the embed info in your HTML element
6. Open Resources in Site Designer and upload the slideshow folder (i.e. cc-slideshow-0ee834e9) to your root
7. Publish your SD website

NOTE: Every time I needed to modify and re-publish my existing slideshow, I deleted the previously automatically generated ID names for each slide and for the Slideshow Container (this ensured the modified slideshow and slides had new auto-generated IDs). I saved the modified slideshow under a new project name. I then followed steps 4-7.

I also made sure to delete all old slideshow folders from my S-Drive.

I followed this method at least ten times making modifications to one slideshow, and though it was tedious, it worked every single time! I hope this helps someone else who might be having issues as well!


Exactly how it is done. I have used RCS and that is the technique I used.
___________
Artist At Heart

Have something to add? We’d love to hear it!
You must have an account to participate. Please Sign In Here, then join the conversation.