Can't open .js files - Post ID 301122

User 2806441 Photo


Registered User
64 posts

Hi, Suddenly the editor (18.890) doesn't open .js files anymore. Can someone help?
User 122279 Photo


Senior Advisor
14,450 posts

Your post made me look into this, and I cannot open js files in the Editor either. I tried to change the program that opens js files, but it didn't help. I can open a new js file with nothing in it, that's all.

Recently I had a similar problem with library files, the ones I had saved had been erased. The HTML Editor has not undergone any changes for quite some time, so I wonder if Windows updates might cause this. I'm running Win 11.

I'll report this.
Ha en riktig god dag!
Inger, Norway

My work in progress:
Components for Site Designer and the HTML Editor: https://mock-up.coffeecup.com


User 2806441 Photo


Registered User
64 posts

Inger, I'm glad I'm not the only one, running win 11 too.
Thanks for reporting.
Ed
User 122279 Photo


Senior Advisor
14,450 posts

After a bit more research found a way to open the js files. You need to have the file extension set to be opened in the Editor. Then go to the folder where those files are actually stored and open them from there. In other words, don't open them from within the app. Once they have been opened once, they should appear in the list of recent files that you see in the Editor when no file is open. Once the js files appear there, it should be possible to click on them to open them from within the app too.

I have sent a report about this to the CC staff.
Ha en riktig god dag!
Inger, Norway

My work in progress:
Components for Site Designer and the HTML Editor: https://mock-up.coffeecup.com


User 2806441 Photo


Registered User
64 posts

Tried that but they don't open at all. Maybe a win 11 thing?
User 122279 Photo


Senior Advisor
14,450 posts

They open for me that way. And I don't KNOW if it's a window thing, I only thought that PERHAPS it could be, because of that other incident I had, with the library files.
I've found another way to open the js files too. Then boot up the HTML Editor, and before you open any other file, try to drag a js file onto the 'canvas'. You then get a warning, but ignore that and click yes.
Ha en riktig god dag!
Inger, Norway

My work in progress:
Components for Site Designer and the HTML Editor: https://mock-up.coffeecup.com


User 2806441 Photo


Registered User
64 posts

Well, that trick worked. Thanks for the tip.
User 379556 Photo


Registered User
1,535 posts

It may be worth checking whether "*.js;" (without the inverted commas) appears in Preferences > Files > Text Files. If it doesn't, it can be added manually. For me it was there already, but I discovered that clicking the Reset button at the end of that line caused it to disappear.

Frank
User 122279 Photo


Senior Advisor
14,450 posts

Frank is correct. So probably it comes down to a bad install.
In my case, I had been testing a new, not yet public build and wanted to go back to the current release. I uninstalled the build I had, then rebooted my machine before installing the current version. For some reason, that '*.js;' didn't appear in the list of supported files.
Now I have uninstalled, rebooted and reinstalled it again, and this time the '*.js;' was included.
Ha en riktig god dag!
Inger, Norway

My work in progress:
Components for Site Designer and the HTML Editor: https://mock-up.coffeecup.com


User 2806441 Photo


Registered User
64 posts

Well, I added *.js to Preferences > Files > Text Files and now it works. Thanks for that tip!

Have something to add? We’d love to hear it!
You must have an account to participate. Please Sign In Here, then join the conversation.