Mobile background images problem

User 1471420 Photo


Registered User
41 posts

Hi everyone :)
I'm having real trouble getting background images to show properly on mobiles. On tablets and desktops its fine.

Ive tried all possible combinations of settings and the best i could get was the background images showing, but enlarged and not to screen size. Other settings such as changing the Origin or Clip of the background, result in no images showing.

I have made new images just for the mobile breakpoint, larger ones for tablet and desktop.

Can anyone point me in the right direction before I go bald??!!

Thanks for any help you can give

:)
User 2088758 Photo


Senior Advisor
2,716 posts

Hi Barry can you please share a link so we get a better grasp on whats going on.

Taking over the world one website at a time!

Steve Kolish
www.misterwebguy.com

YouTube Channel:
https://www.youtube.com/channel/UCL8qVv … ttneYaMSJA
User 1471420 Photo


Registered User
41 posts

Thanks Steve, that would help a bit wouldn't it?
You'll see a slider at the top which works fine, the problem is the background images in the sections underneath. 3 sections, fixed background, none showing. If i remove the Clip and Origin values back to standard the images show but enlarged somehow which is odd as ive made mobile sized images. Confused!

http://skyebluefitness.com/new/

Thank you :)
User 1471420 Photo


Registered User
41 posts

Rather than ask anyone to go over the code on that site for me, which is a heckofa lot to ask on a forum, I was really hoping for some tips. what kind of settings do I need to be aware of when setting the full screen, fixed, mobile background images to look right on phones. Is there any documentation on FF anyone can point me to regarding this?

Thanks in advance for any pointers you can give :)

User 1471420 Photo


Registered User
41 posts


Have something to add? We’d love to hear it!
You must have an account to participate. Please Sign In Here, then join the conversation.