Main Attribute missing


Registered User
94 posts

Why is the Target="value" missing? They have ID & classes so where is target=?
Does anyone know how to make FF add it? Is there a way to amend it to href=?
It is a real pain to have to paste the attribute into the exported source code when you have around 200 to do. Then have to do it again if you make a change.

Example of needed results:<a class="link-button continuw" href="home.html" target="Modal_Window_Brown1_single" id="continue" title="Go To Our Web-Site" >Let's Go Take A Look Around</a>

I posted this by mistake on RSD sorry. I am using RFF. Its is needed there also.
Larry Penny


Senior Advisor
17,791 posts
Online Now

Eric Rohloff wrote:
Try this. Place in the footer
<script>
$(".link-button continuw").attr("target","Modal_Window_Brown1_single");
</script>

I didn't open FF but RSD has the ability to add data target.
I can't hear what I'm looking at.
It's easy to overlook something you're not looking for.

Here's my S-Drive site with
examples of what can be accomplished in VSD.
http://progrower.coffeecup.com/
Here's my CoffeeCup SCCP Shop with examples of what can be done.
http://progrower.coffeecup.com/shop/
This is a site I built for my work.(RSD)
http://esmansgreenhouse.com
This is a site I built for use in my job.(HTML Editor)
https://pestlogbook.com
This is my personnel site used for testing and as an easy way to share photos.(RLM imported to RSD)
http://ericrohloff.com


Registered User
94 posts

Eric Rohloff wrote:
Eric Rohloff wrote:
Try this. Place in the footer
<script>
$(".link-button continuw").attr("target","Modal_Window_Brown1_single");
</script>

I didn't open FF but RSD has the ability to add data target.


Yes FF has Custom Data target-1. I have not been able to figure out how to use it? Does anyone know?
Larry Penny


Senior Advisor
17,791 posts
Online Now

https://zurb.com/university/lessons/oh- … attributes
I can't hear what I'm looking at.
It's easy to overlook something you're not looking for.

Here's my S-Drive site with
examples of what can be accomplished in VSD.
http://progrower.coffeecup.com/
Here's my CoffeeCup SCCP Shop with examples of what can be done.
http://progrower.coffeecup.com/shop/
This is a site I built for my work.(RSD)
http://esmansgreenhouse.com
This is a site I built for use in my job.(HTML Editor)
https://pestlogbook.com
This is my personnel site used for testing and as an easy way to share photos.(RLM imported to RSD)
http://ericrohloff.com


Registered User
93 posts

Go here to learn about "data-" elements: https://developer.mozilla.org/en-US/doc … attributes
Once you accomplish the impossible, then you can move on to the hard stuff!


Registered User
93 posts

Here is a bootstrap example, but FF is basically the same. http://stackoverflow.com/questions/2194 … ootstrap-3
Once you accomplish the impossible, then you can move on to the hard stuff!


Registered User
94 posts

Chuck (ITManager) wrote:
Here is a bootstrap example, but FF is basically the same. http://stackoverflow.com/questions/2194 … ootstrap-3


Now we are starting to get somewhere, thank you. On previous version 329 when I tried to create a custom attribute when I used target= got error word was reserved. Now on 329 it allows me to use target=.
I entered into value box target="Modal_Window_Brown1_single" or should I enter target=Modal_Window_Brown1_single
without the quot.
With the quote below is what I get: <a href="http://e20082006.ezorbcalcium.com/pdf/ez111.pdf" class="responsive-picture picture-link-2" data-custom-1="target=&quot;Modal_Window_Brown1_single&quot;"><picture><img alt="Placeholder Picture" srcset="./socialicons/Images/plantar-fasciitis03.jpg?id=920&amp;cache=1490894907498" src="nodata...image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"></picture></a>
FF puts in &quot instead of " is this correct and FF puts it after class. Is this OK
Entering attribute value as target=Modal_Window_Brown1_single results below:
<a href="http://e20082006.ezorbcalcium.com/pdf/ez111.pdf" class="responsive-picture picture-link-2" data-custom-1="target=Modal_Window_Brown1_single"><picture><img alt="Placeholder Picture" srcset="./socialicons/Images/plantar-fasciitis03.jpg?id=920&amp;cache=1490894907498" src="nodata...image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"></picture></a>
I don't think this is at all correct. No quot.
Larry Penny


Registered User
208 posts

Change Name from data-custom-1 to target and the Value to Modal_Window_Brown1_single :)


Registered User
94 posts

jamo wrote:
Change Name from data-custom-1 to target and the Value to Modal_Window_Brown1_single :)


That does not work either. I Get Warning: The attribute is reserved.

This tells me CC need to fix this.
Larry Penny


Registered User
208 posts

Then you would need to use the JS Eric provided.


Have something to add? We’d love to hear it!
You must have an account to participate. Please Sign In Here, then join the conversation.