Components in Foundation Framer


Senior Advisor
10,997 posts
Online Now

I think it is fairly normal having the slides appear like a list before the page is fully loaded. I've seen it a lot of times.

Steve, where does that slideshow come from? I can't see any evidence of the RCS, is it something that is built into Foundation? It's very nice anyway. :)
Ha en riktig god dag!
Inger, Norway
My new honey site, built with RFF: http://www.horgenhonning.net/
Component sharing for RSD, RFF and RBB: http://www.horgenhonning.net/sharing/



Senior Advisor
2,540 posts

Yes the slide show is a built in component in Foundation Framer. You simple drag and drop the component on the project where you want it. Once its there you just show all the hidden elements to that component and change the placeholder images with your own images.

Keep in mind this component does not trim/cut/crop any photos. Its a manual process right now. You will have to resize and crop each photo in the slideshow at each breakpoint. The good thing is it does give you suggested sizes of the images right on the placeholder at each breakpoint.
Taking over the world one website at a time!

Steve Kolish
www.misterwebguy.com

YouTube Channel:
https://www.youtube.com/channel/UCL8qVv … ttneYaMSJA


VP of Software Development
49,402 posts

Inger wrote:
I think it is fairly normal having the slides appear like a list before the page is fully loaded. I've seen it a lot of times.

Steve, where does that slideshow come from? I can't see any evidence of the RCS, is it something that is built into Foundation? It's very nice anyway. :)

It is called Orbit, and it is part of Foundation. The issue you mentioned in the other topic discussion with all the images loading at first can be addressed by adding a Max-Height to the List Container.

If you follow through the example markup here, you can build this one identically in Foundation Framer.

http://foundation.zurb.com/sites/docs/orbit.html

Attached is the Orbit slider created by Foundation Framer.
Attachments:
Learn the essentials with these quick tips for Responsive Site Designer, Responsive Email Designer, Foundation Framer, and the new Bootstrap Builder. You'll be making awesome, code-free responsive websites and newsletters like a boss.


Registered User
49 posts

I have been working my way through the Foundation components and I read on the Foundation site that 'Orbit' is no longer supported (typical, just as I was getting my head around how it worked!. Not that it really matters, I like Orbit, it works well.).
However, on the Foundation site they are promoting 'Slick', is this going to be reflected in FF?


Registered User
49 posts

Thanks Scott, I appreciate all you guys are doing.


Ambassador
352 posts

I am having trouble assigning a data-timer-delay attribute. What element does one apply the attribute to? I tried everything with the orbit class. If I apply it to the main container, the slide is broken, as well if I apply it to the list item container.


Ambassador
352 posts

OK - I think I figured it - out - or it fixed itself. I came back, restarted comp and with a fresh copy, applied the time to the container, and it works. And to be honest, I remember - that I forgot to check my mouse to make sure it was off the slider.

Is there a way to apply a timer to individual slides? If I apply a the data-timer-delay to a list-item container, it seems to have no effect.


Ambassador
352 posts

Inger wrote:


Steve, where does that slideshow come from? I can't see any evidence of the RCS, is it something that is built into Foundation? It's very nice anyway. :)


Doing to work on a slider to learn Foundation and I just learned that the Orbit is deprecated. Foundation ended it 2 years ago and published a list of suggestions, but it will remain in the framework. So, you will probably, hopefully find better capability with RCS (I am too unfamiliar to compare both)


Registered User
2 posts

Hi, I'm working on a trial version of RFF.

I have set up a symbol for the navigation menu, nav-bar, but I cannot add it to subsequent pages. I have tried clicking, double clicking and dragging from the symbol name, the plus sign, and the preview area but no matter what I do the symbol is not added to the new page.

What am I doing wrong?


Senior Advisor
10,997 posts
Online Now

Did you also click on the page where you want it to appear before you clicked the plus sign?
Ha en riktig god dag!
Inger, Norway
My new honey site, built with RFF: http://www.horgenhonning.net/
Component sharing for RSD, RFF and RBB: http://www.horgenhonning.net/sharing/



Have something to add? We’d love to hear it!
You must have an account to participate. Please Sign In Here, then join the conversation.