Web Form not sending

User 1861272 Photo


Registered User
339 posts

The web form I just built is not sending, it only opens my default email.
I put the recipients address in the Action tab, is that correct? I used mailto: prior to the address, could that be the issue? It's uploaded at https://www.josephclarkgallery.com/contact-us.html
User 187934 Photo


Senior Advisor
19,678 posts

All mail settings in the Form Builder are done within the app under the Notification Tab or Confirmation tab.
I can't hear what I'm looking at.
It's easy to overlook something you're not looking for.

This is a site I built for my work.(RSD)
http://esmansgreenhouse.com
This is a site I built for use in my job.(HTML Editor)
https://pestlogbook.com
This is my personal site used for testing and as an easy way to share photos.(RLM imported to RSD)
https://ericrohloff.com
User 1861272 Photo


Registered User
339 posts

Thanks Eric. Guess I'm dumb but where are the Notification Tab or Confirmation tabs? I've looked through everywhere and do not see any tabs named that.
User 187934 Photo


Senior Advisor
19,678 posts

Click on "Setting" at the top left of the app.
I can't hear what I'm looking at.
It's easy to overlook something you're not looking for.

This is a site I built for my work.(RSD)
http://esmansgreenhouse.com
This is a site I built for use in my job.(HTML Editor)
https://pestlogbook.com
This is my personal site used for testing and as an easy way to share photos.(RLM imported to RSD)
https://ericrohloff.com
User 1861272 Photo


Registered User
339 posts

Thanks again Eric, but that only opens the Settings for publishing the form.
The form is online but the Submit button only opens a default email, it does not send the form.
User 2699991 Photo


Registered User
3,750 posts
Online Now

Tim Banish Sr wrote:
Thanks again Eric, but that only opens the Settings for publishing the form.
The form is online but the Submit button only opens a default email, it does not send the form.


As you suspected before you are overiding the button action by placing the email:to

</label><button type="submit" class="button" formaction="mailto:josephclarkgallery@gmail.com"><span class="submit-text-2">SUBMIT</span></button>

You set where to send the form to, and a confirmation email sent to the clients email. in the webform settings

and just as an aside
the form on my mobile device is way off to the right (needs scrolling to get it, and on my desktop monitor its way way too wide (not just the form but everything.)

This is what would be classed as not a good user experience which could effect any SEO

The Help You Need: When You Need It The Most
Website Design & Development
Website Renovations
Wayans' Theme Park
Watch Listen & Learn Video Tutorials
User 1861272 Photo


Registered User
339 posts

Thanks Wayan,
I know the form needs size adjustments but I'm just trying to get it working first.
I don't see webform settings, can you please expand on where I can find that?
User 2699991 Photo


Registered User
3,750 posts
Online Now

Tim Banish Sr wrote:
Thanks Wayan,
I know the form needs size adjustments but I'm just trying to get it working first.
I don't see webform settings, can you please expand on where I can find that?

It's not just your form

I don't really understand what you have some, normally one cannot export without completing the confirmation and notification fields, it normally gives a warning to do so.
So all you need do is remove that mailto:. gubbins from the buttonin site designer

The Help You Need: When You Need It The Most
Website Design & Development
Website Renovations
Wayans' Theme Park
Watch Listen & Learn Video Tutorials
User 187934 Photo


Senior Advisor
19,678 posts

Are you using Form Builder? Form Designer maybe???
I can't hear what I'm looking at.
It's easy to overlook something you're not looking for.

This is a site I built for my work.(RSD)
http://esmansgreenhouse.com
This is a site I built for use in my job.(HTML Editor)
https://pestlogbook.com
This is my personal site used for testing and as an easy way to share photos.(RLM imported to RSD)
https://ericrohloff.com
User 2699991 Photo


Registered User
3,750 posts
Online Now

Eric Rohloff wrote:
Are you using Form Builder? Form Designer maybe???


I can't find any reference to webform builder at al on that pagel, there are no files no php no html element with the iframe script that one is supposed to paste into the heeder of a html element.

The Help You Need: When You Need It The Most
Website Design & Development
Website Renovations
Wayans' Theme Park
Watch Listen & Learn Video Tutorials

Have something to add? We’d love to hear it!
You must have an account to participate. Please Sign In Here, then join the conversation.