Form design element focus - Post ID...

User 2902462 Photo


Registered User
45 posts
Online Now

I select an element to focus on when the form is opened. But on my computer the focus does not show up. I have opened the form in another computer and I can see that it works. I'm using Windows 10 with Norton. Any ideas?
David Doyle
User 187934 Photo


Senior Advisor
18,666 posts
Online Now

Hi David,
Can you share a link and or your project file?
I can't hear what I'm looking at.
It's easy to overlook something you're not looking for.

Here's my S-Drive site with
examples of what can be accomplished in VSD.
https://progrower.coffeecup.com/
Here's my CoffeeCup SCCP Shop with examples of what can be done.
https://progrower.coffeecup.com/shop/
This is a site I built for my work.(RSD)
http://esmansgreenhouse.com
This is a site I built for use in my job.(HTML Editor)
https://pestlogbook.com
This is my personal site used for testing and as an easy way to share photos.(RLM imported to RSD)
https://ericrohloff.com
User 2902462 Photo


Registered User
45 posts
Online Now

Here is a link to the form on line http://www.telgogolf.com/contact.html
This is my project file
Attachments:
David Doyle
User 187934 Photo


Senior Advisor
18,666 posts
Online Now

Hi David,
Since your form is hosted on S-Drive I would open a support topic and ask the CC gurus why it's not working on the embedded form but works on the actual form.
Auto focus works here.
http://telgogolf.coffeecup.com/forms/Contact%20Form/
Support topic
https://www.coffeecup.com/help/myroom/opentopic/
I can't hear what I'm looking at.
It's easy to overlook something you're not looking for.

Here's my S-Drive site with
examples of what can be accomplished in VSD.
https://progrower.coffeecup.com/
Here's my CoffeeCup SCCP Shop with examples of what can be done.
https://progrower.coffeecup.com/shop/
This is a site I built for my work.(RSD)
http://esmansgreenhouse.com
This is a site I built for use in my job.(HTML Editor)
https://pestlogbook.com
This is my personal site used for testing and as an easy way to share photos.(RLM imported to RSD)
https://ericrohloff.com
User 379556 Photo


Registered User
886 posts

On my Windows 10 computer the autofocus of http://www.telgogolf.com/contact.html
(a) works in Chrome, Opera, Midori;
(b) doesn't work in Firefox, Internet Explorer 11, Edge.

I notice that the code output by FB Preview is
<div class="fb-input-box">
<input name="Name" id="item2_text_1" autofocus type="text" maxlength="20"
placeholder="" autocomplete="off" data-hint="" />
</div>

Somehow this has got changed to
<div class="fb-input-box">
<input name="Name" id="item2_text_1" autofocus="" maxlength="20" placeholder="" data-hint="" autocomplete="off" type="text">
</div>

I'm therefore wondering whether Serif WebPlus X8 (I also used to use that) didn't support HTML 5, and changed the code when it found it in an HTML box.

Entering (without the inverted commas) 'html autofocus not working' in Google suggests that autofocus failures can be the result of many different causes, including browser issues and timing of page loading.

Frank

Have something to add? We’d love to hear it!
You must have an account to participate. Please Sign In Here, then join the conversation.