Can't hook Form Designer form to Web...

User 187934 Photo


Senior Advisor
19,684 posts

Hi Judi,
Can you share a link to your form?
I can't hear what I'm looking at.
It's easy to overlook something you're not looking for.

This is a site I built for my work.(RSD)
http://esmansgreenhouse.com
This is a site I built for use in my job.(HTML Editor)
https://pestlogbook.com
This is my personal site used for testing and as an easy way to share photos.(RLM imported to RSD)
https://ericrohloff.com
User 2905946 Photo


Registered User
15 posts

Form Designer form
https://www.onguarddefense.com/newsite/ … /form.html

Web Form Builder paths
https://www.onguarddefense.com/newsite/ … tform1.php
https://www.onguarddefense.com/newsite/ … form1.html

I have not linked into an actual web page yet. I have it connecting at this point.
What I tried was eliminating the "submit" button actions and only put actions on the form container:
ACTION:
../testform1.php

Method:
Post

Enctype:
Multipart form Data

Autofocus:
Name

attributes
Data Abide - but field is blank

I get the email now but it never selects the radio buttons and identifies what was selected. In Form builder I have a "group" called radio and then in that group there is a radio button (radio 1, radio 2, radio 3). I see how to add the radio buttons to the Web Form Desiginer, but it doesn't seem to have an associated radio "group"

this is a snippet from the web form builder html that does work.

<div class="fb-radio">
<label id="item5_0_label"><input name="radio" id="item5_0_radio" type="radio" checked data-hint="" value="Radio 1" /><span class="fb-fieldlabel" id="item5_0_span">Radio 1</span></label>
<label id="item5_1_label"><input name="radio" id="item5_1_radio" type="radio" value="Radio 2" /><span class="fb-fieldlabel" id="item5_1_span">Radio 2</span></label>
<label id="item5_2_label"><input name="radio" id="item5_2_radio" type="radio" value="Radio 3" /><span class="fb-fieldlabel" id="item5_2_span">Radio 3</span></label>
</div>
User 2905946 Photo


Registered User
15 posts

I figured it out - it was looking for the id created by the web form builder. I got it working with the site designer form components, I'm not sure if I want to use the form designer now, or not. Seems like site designer has most of the functionality as the form designer - and I don't really understand the constant red error messages with every element in form designer. That doesn't seem to make sense where it's on vs. off. Seems to be on all the time.

Anyhow, I think I got it going.
User 187934 Photo


Senior Advisor
19,684 posts

Change the name of your radio buttons in your Form Designer Form to
radio
I can't hear what I'm looking at.
It's easy to overlook something you're not looking for.

This is a site I built for my work.(RSD)
http://esmansgreenhouse.com
This is a site I built for use in my job.(HTML Editor)
https://pestlogbook.com
This is my personal site used for testing and as an easy way to share photos.(RLM imported to RSD)
https://ericrohloff.com
User 2905946 Photo


Registered User
15 posts

Got it working now = didn't use form designer but just the site designer.

I think it looks pretty good now: have a look if you like:

onguarddefense.com/newsite/training.html

Have something to add? We’d love to hear it!
You must have an account to participate. Please Sign In Here, then join the conversation.