Script doubled on page after export -...

User 188640 Photo


Registered User
862 posts

I am rebuilding an html table based website in SD 5 Build 3470. I have everything complete with one exception. When I export the site the form script is where it's supposed to be in it's html element but it is also being added to the end of the head section.

Has anyone else had this happen and if so what is the fix?

It's been a long day and I'm calling it a day.

Thanks for any insight,
Ernie
A Rose is Just a Weed in a Corn Patch!
User 187934 Photo


Senior Advisor
19,684 posts

Link?
I can't hear what I'm looking at.
It's easy to overlook something you're not looking for.

This is a site I built for my work.(RSD)
http://esmansgreenhouse.com
This is a site I built for use in my job.(HTML Editor)
https://pestlogbook.com
This is my personal site used for testing and as an easy way to share photos.(RLM imported to RSD)
https://ericrohloff.com
User 188640 Photo


Registered User
862 posts

I'll have to do that tomorrow. I have the site up on my testing domain for the client to look at and I manually took the extra script out. I will do that first thing in the morning and post a link.

Thanks Eric
A Rose is Just a Weed in a Corn Patch!
User 188640 Photo


Registered User
862 posts

Eric,
Here's a link to my testing domain and the website: https://mytestblog.net/fpc/index.html

I uploaded the page with a modified name because I didn't want to change the off canvas menu. Here's a direct link to the one with the double script: https://mytestblog.net/fpc/reservations2.html

Thanks,
Ernie
A Rose is Just a Weed in a Corn Patch!
User 187934 Photo


Senior Advisor
19,684 posts

Check your head section on your page in SD. It looks as though you might have pasted the code in there.
I can't hear what I'm looking at.
It's easy to overlook something you're not looking for.

This is a site I built for my work.(RSD)
http://esmansgreenhouse.com
This is a site I built for use in my job.(HTML Editor)
https://pestlogbook.com
This is my personal site used for testing and as an easy way to share photos.(RLM imported to RSD)
https://ericrohloff.com
User 188640 Photo


Registered User
862 posts

I'll take a look at that. I went through all that when this first appeared but maybe I missed that.

Edit: It's not in the head section on the elements area or the head section in the page manager.

I tried exporting the site again thinking maybe some kind of a glitch but it's the same.

Is there a head area besides the two I mentioned?
A Rose is Just a Weed in a Corn Patch!
User 122279 Photo


Senior Advisor
13,772 posts
Online Now

Not really. But did you use an HTML element in addition to the two areas that you mentioned?
Ha en riktig god dag!
Inger, Norway
This site was made before we were able to create components through the app:
Component sharing for RFF, RBB, RSD and SD: https://eikweb.com/sharing/
My work in progress right now:
Components for the same as above + HTML Editor: https://mock-up.coffeecup.com


User 188640 Photo


Registered User
862 posts

It has an html element in it's own container. I did the same with the contact form and it doesn't add the script to the head section.
A Rose is Just a Weed in a Corn Patch!
User 187934 Photo


Senior Advisor
19,684 posts

Can you share your project file?
I can't hear what I'm looking at.
It's easy to overlook something you're not looking for.

This is a site I built for my work.(RSD)
http://esmansgreenhouse.com
This is a site I built for use in my job.(HTML Editor)
https://pestlogbook.com
This is my personal site used for testing and as an easy way to share photos.(RLM imported to RSD)
https://ericrohloff.com
User 188640 Photo


Registered User
862 posts

https://mytestblog.net/files/FishPondCabins.rsd

I hope that link works. I'll check it right after I post in case.
A Rose is Just a Weed in a Corn Patch!

Have something to add? We’d love to hear it!
You must have an account to participate. Please Sign In Here, then join the conversation.