Text boxes not visible after...

User 2183682 Photo


Registered User
25 posts

While creating a test page with VSD for my team to review, I found that embedding a form into my website with Web Form Builder caused all the text boxes on my test page to disappear. The test page is located at http://www.haleycurlsforhope.org/test.html a duplicate of the page with the from deleted is found at http://www.haleycurlsforhope.org/test2.html Any ideas what might cause this?

Regards,
Kim
User 38401 Photo


Senior Advisor
10,951 posts

hiya Kim,

I'm not 100% sure here, but it does look like there's an end div </div> missing after the form code that was entered into the site. You're using VSD so I don't know how to tell you to correct it, but maybe it's a matter of the place you were telling it to go? Hopefully someone else will have some suggestions there.

The link for your 2nd test page isn't working also, if you want to post the correct link there I'll fix it for you in the top post and I'll delete the fix post.
User 126492 Photo


Ambassador
1,507 posts

Kim.

I corrected the links for you.

I can see one problem and that is you have not used the </iframe> closing tag where you have embedded your form. The code should look something like this:-

<iframe width="402" height="468" style="border:none; background:transparent; overflow:hidden;" src="volunteerhours/volunteerhours.html">You need a Frames Capable browser to view this content.</iframe>


You did however use the closing iframe tag for the mapguest link.
Jim
---------------------------
User 126492 Photo


Ambassador
1,507 posts

Kim

have a look for the div class="Object1557" on your page. After the javascript code for your form you will see that you have a tag <noscript> - remove that and your text boxes will come back.

Just wondering why you have used the javascript code for the form and then an ifarme loading the page with the form on again. You don't need the second iFrame.
Jim
---------------------------
User 187934 Photo


Senior Advisor
19,931 posts

Looks to me that she's missing a </noscript> at the end of the FB code.:)
Kim remove all the code and try re-pasting it to your html box. In Form builder use the copy to clipboard to grab the code then paste it into your html box.
You need to be careful when removing the Coffeecup reference in the code.;)
I can't hear what I'm looking at.
It's easy to overlook something you're not looking for.

This is a site I built for my work.(RSD)
http://esmansgreenhouse.com
This is a site I built for use in my job.(HTML Editor)
https://pestlogbook.com
This is my personal site used for testing and as an easy way to share photos.(RLM imported to RSD)
https://ericrohloff.com
User 126492 Photo


Ambassador
1,507 posts

When I export a form there is no mention of <noscript> or </noscript> in the code you are given by Form Builder, just the iframe code.
Jim
---------------------------
User 187934 Photo


Senior Advisor
19,931 posts

It's in every script the form builder generates for me.:)
Attachments:
I can't hear what I'm looking at.
It's easy to overlook something you're not looking for.

This is a site I built for my work.(RSD)
http://esmansgreenhouse.com
This is a site I built for use in my job.(HTML Editor)
https://pestlogbook.com
This is my personal site used for testing and as an easy way to share photos.(RLM imported to RSD)
https://ericrohloff.com
User 126492 Photo


Ambassador
1,507 posts

I don't get that.......

Ver 1.1 3173

Attachments:
Jim
---------------------------
User 1948478 Photo


Senior Advisor
1,850 posts

Jim Cantrell wrote:
I don't get that.......
Ver 1.1 3173

LOL... I was just about to post with a confirmation that, like Jim, I get only the <iframe> code when I export. But then I thought I'd test it with the latest Build (3261), and found to my surprise that I now get the whole enchilada with scripts and noscripts and iframes an' all...!
My working forms were built with a previous Build and they all contain only the iframe code.
So why was it suddenly considered a good idea to put in all the extra stuff in the later Builds...?
User 187934 Photo


Senior Advisor
19,931 posts

CC just trying to keep us sharp.:lol:
I can't hear what I'm looking at.
It's easy to overlook something you're not looking for.

This is a site I built for my work.(RSD)
http://esmansgreenhouse.com
This is a site I built for use in my job.(HTML Editor)
https://pestlogbook.com
This is my personal site used for testing and as an easy way to share photos.(RLM imported to RSD)
https://ericrohloff.com

Have something to add? We’d love to hear it!
You must have an account to participate. Please Sign In Here, then join the conversation.