Submit problem - Post ID 288664

User 2056177 Photo


Registered User
226 posts

If I remove the conditional, the send button does not appear as it's a regular expression.

The link is: https://tvbr.org.uk/test.html
User 187934 Photo


Senior Advisor
18,798 posts

Let me look at it. I thought it worked as I posted.
I can't hear what I'm looking at.
It's easy to overlook something you're not looking for.

Here's my S-Drive site with
examples of what can be accomplished in VSD.
https://progrower.coffeecup.com/
Here's my CoffeeCup SCCP Shop with examples of what can be done.
https://progrower.coffeecup.com/shop/
This is a site I built for my work.(RSD)
http://esmansgreenhouse.com
This is a site I built for use in my job.(HTML Editor)
https://pestlogbook.com
This is my personal site used for testing and as an easy way to share photos.(RLM imported to RSD)
https://ericrohloff.com
User 2056177 Photo


Registered User
226 posts

The latest version of the form is now at:

www.tvbr.org.uk/test.html

Pete
User 187934 Photo


Senior Advisor
18,798 posts

I would take a look at your form as you have several inputs duplicated. The problem is your hiding inputs with the custom js but they are set to required and the form builder doesn't know this. Delete the extra inputs and adjust the code to reflect the change as the item # will be different.
1. ® Is your boxer housetrained?
2. ® Does your boxer have any allergy problems?
3. ® Is your boxer good with adults?



I can't hear what I'm looking at.
It's easy to overlook something you're not looking for.

Here's my S-Drive site with
examples of what can be accomplished in VSD.
https://progrower.coffeecup.com/
Here's my CoffeeCup SCCP Shop with examples of what can be done.
https://progrower.coffeecup.com/shop/
This is a site I built for my work.(RSD)
http://esmansgreenhouse.com
This is a site I built for use in my job.(HTML Editor)
https://pestlogbook.com
This is my personal site used for testing and as an easy way to share photos.(RLM imported to RSD)
https://ericrohloff.com
User 2056177 Photo


Registered User
226 posts

The reason for the duplicated inputs is that if you set the conditions in the element you want to show next, the "is not empty" condition does not bring up the the element.

This is something that has never worked and has always been a problem with WFB.

Pete
User 187934 Photo


Senior Advisor
18,798 posts

If your keeping them you need to add to the script to disable or make them not required.
I can't hear what I'm looking at.
It's easy to overlook something you're not looking for.

Here's my S-Drive site with
examples of what can be accomplished in VSD.
https://progrower.coffeecup.com/
Here's my CoffeeCup SCCP Shop with examples of what can be done.
https://progrower.coffeecup.com/shop/
This is a site I built for my work.(RSD)
http://esmansgreenhouse.com
This is a site I built for use in my job.(HTML Editor)
https://pestlogbook.com
This is my personal site used for testing and as an easy way to share photos.(RLM imported to RSD)
https://ericrohloff.com

Have something to add? We’d love to hear it!
You must have an account to participate. Please Sign In Here, then join the conversation.