Proceed button doesn't proceed to...

User 2502039 Photo

Registered User
2 posts

I'm responsible for a small charity website that includes a Web Form Builder form.

The form includes Paypal payment and uploads the results to Sdrive. When the proceed button is pressed the results are being uploaded into Sdrive but the form itself just resets and does not proceed to the Paypal checkout page.

Although I've been using this form successfully for a number of years I have been aware for a while that some Safari users have had this issue. However after a minor form update to prices on the form this morning I seem to be having the same problem with all browsers that I've tried.

Accessing the form directly from CoffeeCup forms works fine:

Until now the form was embedded into the page using the code generated by Web Form Builder. I've tried putting it on the website using the Coffeecup form address above into an Iframe but that gives me the same result.

I've temporarily put a link to the off-site version of the form onto the website to handle requests at the moment. The regular version of the page can be found here:

A hunch I have is that the site doesn't have an SSL certificate and this may be causing this, but then why would it only occur after a minor update this morning? Also the page shows up in my browsers as unsecure so from that point of view appears to be the same.

Any help would be greatly appreciated.

User 187934 Photo

Senior Advisor
19,949 posts
Online Now

Hi Jayne,
It looks like your page needs to have it's html type declaration updated.
It also has a lot of invalid code. … mp;group=0
I would try that first. https would also be a good thing as browser are getting fickle about it.
I can't hear what I'm looking at.
It's easy to overlook something you're not looking for.

This is a site I built for my work.(RSD)
This is a site I built for use in my job.(HTML Editor)
This is my personal site used for testing and as an easy way to share photos.(RLM imported to RSD)
User 2502039 Photo

Registered User
2 posts

Thanks Eric,

What you say makes sense; the site dates back about 15 years and it's a mess, I'm well aware of that. I guess I need to start again, and get an SSL certificate. Strange that it should suddenly become a major issue just after I'd updated the form though.

Thanks for your assistance.

Have something to add? We’d love to hear it!
You must have an account to participate. Please Sign In Here, then join the conversation.