PHP error strange behavior - Page 1

User 2312005 Photo


Registered User
59 posts

When someone fills out my form without putting the right email format, it redirects to Contact form PHP which is barely readable, white font on white background. I am not blaming the web form builder, maybe I made a mistake somewhere. Here is the link to my contact form and attached the error page
http://www.ericphotoart.com/contact.html

Is there a way to correct it in PHP? I don't remember any options in Web Form Builder to set up the error page
Attachments:
http://www.ericphotoart.com - my website
http://www.istockphoto.com/ericsphotography - my stock photography profile and portfolio
User 187934 Photo


Senior Advisor
19,949 posts

What version of PHP is on your host? You need at least 5.1
I can't hear what I'm looking at.
It's easy to overlook something you're not looking for.

This is a site I built for my work.(RSD)
http://esmansgreenhouse.com
This is a site I built for use in my job.(HTML Editor)
https://pestlogbook.com
This is my personal site used for testing and as an easy way to share photos.(RLM imported to RSD)
https://ericrohloff.com
User 2312005 Photo


Registered User
59 posts

It's Godaddy - PHP 5.2
http://www.ericphotoart.com - my website
http://www.istockphoto.com/ericsphotography - my stock photography profile and portfolio
User 103173 Photo


VP of Software Development
0 posts

You are quite a few versions behind with Web Form Builder.

http://www.ericphotoart.com/Contact%20f … ertest.php

You are on build 2986. I would suggest upgrading your form in the latest version and then re-export your files back to your server and see how that goes.

Upgrades are free, so why not take advantage of them right? :)
Learn the essentials with these quick tips for Responsive Site Designer, Responsive Email Designer, Foundation Framer, and the new Bootstrap Builder. You'll be making awesome, code-free responsive websites and newsletters like a boss.
User 2312005 Photo


Registered User
59 posts

You were absolutely right Scott! I downloaded the latest version V.3026 re uploaded the forms and everything works as it supposed to. Also the new version requires only <Body> entry what I noticed.
I only miss a "reset" button so I will need to search the web for some java script.
So I have two forms on my website and both are working ! Thanks guys.

http://www.ericphotoart.com/contact.html
http://www.ericphotoart.com/modelingtips.html
http://www.ericphotoart.com - my website
http://www.istockphoto.com/ericsphotography - my stock photography profile and portfolio
User 271042 Photo


Ambassador
85 posts

Hi Eric,

I was going to do a screen cast, but my cat's asleep on my headphones and microphone!

Anyway, in version 3026 there IS an option for a "reset" button - choose "Button" from the menu, then in Form Settings change the default button type from Submit to Reset (change the label too, of course!)

Regards,

Phil
http://www.gr8-knots.com

Nostalgia isn't what it used to be.
User 2312005 Photo


Registered User
59 posts

Thanks Phil. So I've tried that but I can't add another button to the form. I can change the label from submit to reset but then I would not have the submit button. Am I missing something? Where to change the default button type in Form setting?
http://www.ericphotoart.com - my website
http://www.istockphoto.com/ericsphotography - my stock photography profile and portfolio
User 271042 Photo


Ambassador
85 posts

Hi Eric,

Your forms only appear to have one button, so I can't understand why you cannot add another one. Anyway, take a look at the link below, it may help. Other folks might have advice too -

http://www.screencast.com/t/gUWhTwY0w

Phil
http://www.gr8-knots.com

Nostalgia isn't what it used to be.
User 166871 Photo


Registered User
185 posts

Phil
Which version of Form Builder are you referencing? Your screencast is of the classic or flash based-version, this thread is for the HTML version and I, like Eric do not see a way to add multiple buttons in version 3033 of Webformbuilder. Please confirm. BTW I really like your screencast videos
Cayucostom
Vista Tom


User 2114410 Photo


Registered User
383 posts

Ericphotoart wrote:

So I have two forms on my website and both are working ! Thanks guys.

http://www.ericphotoart.com/contact.html
http://www.ericphotoart.com/modelingtips.html


I really like your forms. :)

As I'm so behind in updates :(, and plan to update & get to my forms early in the New Year, are your forms transparent- or were you lucky enough to get a theme to match in with VSD? I really like the look you've achieved, so any advice will shortcut this look for me, thanks. :)

Have something to add? We’d love to hear it!
You must have an account to participate. Please Sign In Here, then join the conversation.