Two images for the list items?

User 10077 Photo


Senior Advisor
975 posts

This is my first sitemapper attempt, and the first time I've developed one for human viewing. Everything shows up correctly EXCEPT (isn't there always a "but") each list item shows both the sitmapper arrow and the dot image used on the site for the regular list items.

I'm assuming this is a css issue somewhere.
Suggestions for fixes?

Brian

Want personal and specialized help with RLM, RSD or with converting your VSD (or other) site to RLM/RSD? Email me at cchelp@uscni.org or call 865-687-7698.
User 10077 Photo


Senior Advisor
975 posts

Ok, I found the issue. The css used for the site defines the dot image to be used for list elements. How can I disallow that for this page?
Brian

Want personal and specialized help with RLM, RSD or with converting your VSD (or other) site to RLM/RSD? Email me at cchelp@uscni.org or call 865-687-7698.
User 2088758 Photo


Senior Advisor
2,618 posts

Do you have a link?
Taking over the world one website at a time!

Steve Kolish
www.misterwebguy.com

YouTube Channel:
https://www.youtube.com/channel/UCL8qVv … ttneYaMSJA
User 10077 Photo


Senior Advisor
975 posts

Oops! Sorry.

http://bobjohnsonins.com/sitemap.php
Brian

Want personal and specialized help with RLM, RSD or with converting your VSD (or other) site to RLM/RSD? Email me at cchelp@uscni.org or call 865-687-7698.
User 2088758 Photo


Senior Advisor
2,618 posts

I'm still looking... there has to be some css somewhere that is making this happen. I have used the sitemapper for a long time and never encountered this.
Taking over the world one website at a time!

Steve Kolish
www.misterwebguy.com

YouTube Channel:
https://www.youtube.com/channel/UCL8qVv … ttneYaMSJA
User 187934 Photo


Senior Advisor
18,063 posts

Move your sitemap.css style sheet link to below all the rest in the head of your page.
I can't hear what I'm looking at.
It's easy to overlook something you're not looking for.

Here's my S-Drive site with
examples of what can be accomplished in VSD.
http://progrower.coffeecup.com/
Here's my CoffeeCup SCCP Shop with examples of what can be done.
http://progrower.coffeecup.com/shop/
This is a site I built for my work.(RSD)
http://esmansgreenhouse.com
This is a site I built for use in my job.(HTML Editor)
https://pestlogbook.com
This is my personnel site used for testing and as an easy way to share photos.(RLM imported to RSD)
http://ericrohloff.com
http://ericrohloff.com/property/
User 10077 Photo


Senior Advisor
975 posts

Ok. So CSS gives precedence to the last setting for an element. When I moved the Sitemapper links after the other css links, it fixed the list items, but broke the background. Therefore, right before the head ends, I added a blank image for the list element.

<style type="text/css">
<!--
li{list-style-image: url();}
-->
</style>

That seems to work. I'm open to any better ideas.
Brian

Want personal and specialized help with RLM, RSD or with converting your VSD (or other) site to RLM/RSD? Email me at cchelp@uscni.org or call 865-687-7698.
User 187934 Photo


Senior Advisor
18,063 posts

That's what I typically do to fix a one page issue.
I can't hear what I'm looking at.
It's easy to overlook something you're not looking for.

Here's my S-Drive site with
examples of what can be accomplished in VSD.
http://progrower.coffeecup.com/
Here's my CoffeeCup SCCP Shop with examples of what can be done.
http://progrower.coffeecup.com/shop/
This is a site I built for my work.(RSD)
http://esmansgreenhouse.com
This is a site I built for use in my job.(HTML Editor)
https://pestlogbook.com
This is my personnel site used for testing and as an easy way to share photos.(RLM imported to RSD)
http://ericrohloff.com
http://ericrohloff.com/property/

Have something to add? We’d love to hear it!
You must have an account to participate. Please Sign In Here, then join the conversation.