SiteMapper spidering problem / Not finding pages


Registered User
107 posts

When I use the SiteMapper default of spidering my website, it only finds the index (home) page and one other page out of 90 pages! When I use the "browse for files" option and locate the index page in my website files, all 90 pages show up though. Why can't the spidering my website option find them? There is an issue because even though I uploaded to Google all 90 pages using my index files, only the two pages that showed up using spidering option show up when I type in the direct URL of the page name. Even though Google shows all 90 pages as indexed. What is going on here?
HELP!!!
Member of the lumpen proletariat. Another cog in the wheel. Possibly a major pain in the ass soon.


Ambassador
1,130 posts

Poolman,
Can you post your link here so I can try it out with my SiteMapper and see if I can help.


Ambassador
2,174 posts

ad99wd,

I'm gonna go out on a limb and say this is probably the site he's talking about... http://www.hydrobluepools.com/ Hope I'm right, don't want to waste anyone's time.
Living the dream, stocking the cream :D


Ambassador
1,130 posts

Phill, I hope you are right as I just made a site map of this domain name.

Poolman
If this is your site then my Site Mapper worked. I got a total of 83 pages. I have attached all your sitemap files below in a zip file. All you have to do now is save the attached file, unzip it and upload them to your site.


Attachments:


Registered User
107 posts

Hi guys,

I was informed by CC that the spider will not read flash, which is what my menu is. There were no other html links on the pages so SiteMapper could not find them. Thanks for taking your time out to assist. Much appreciated.
Member of the lumpen proletariat. Another cog in the wheel. Possibly a major pain in the ass soon.


Ambassador
3,144 posts

Poolman,

Some people do not allow flash, and screen readers will also have a problem with a flash menu. One solution is to put some links at the bottom of your site. I use a standard footer that has links to each major section of my site, and then I have links on those pages in the content. It works nice and I have a menu that looks nice and there is still something for those that have flash and javascript turned off.


Registered User
8 posts

I'm having the same issue with the newest version of sitemapper. It only finds one html file but it isn't even the index file. It only finds the copyright page. I'm using a javascript menu file. Is that the issue?

http://www.northwestscenescapes.net


VP of Software Development
49,402 posts

I looked at your site and there is not one link outside some sort of JavaScript. That is why it cannot find anything.
Learn the essentials with these quick tips for Responsive Site Designer, Responsive Email Designer, Foundation Framer, and the new Bootstrap Builder. You'll be making awesome, code-free responsive websites and newsletters like a boss.


Registered User
8 posts

Rats. Thanks. So should I add a "text" menu at the bottom of the index page? Could sitemapper find all the files then?


Registered User
9 posts

I have the same problem and it drives me nuts. Sitemapper finds only the index page in site www.kerolamps.com; I reviewed all and nothing I have done made a difference. It has a similar DHTML menu as my other site www.visitmajorscreek.com which it crawls without problems. Please help to restore my sanity!

Have something to add? We’d love to hear it!
You must have an account to participate. Please Sign In Here, then join the conversation.