Small issue with Menu Builder inside...

User 2098239 Photo


Registered User
15 posts

Hello all.
I have a small issue when my web page gets below a set width and the menu is supposed to switch between horizontal to a mobile vertical menu.

It seems that before the menu would shift everything on the page down to make room..but at this time the page stays as it is and only part of the sub menu is visible..

Almost like the z-value is behind the other content..

I have looked through bat cant see where the issue is ?

If possible could someone take a quick glance, as you may be able to point me in the direction of my error :)

The issue can be seen here : http://www.yarakbirdsofprey.co.uk/index.php
just resize browser down until it switches to mobile, you will see the menu is behind the content .

Many thanks
Carl
User 2088758 Photo


Senior Advisor
2,716 posts

I have seen that before Carl. What version of menu builder are you using? Check your coffeecup software account and see if you are using the most up to date version.

Taking over the world one website at a time!

Steve Kolish
www.misterwebguy.com

YouTube Channel:
https://www.youtube.com/channel/UCL8qVv … ttneYaMSJA
User 187934 Photo


Senior Advisor
18,676 posts

Your missing these files.
http://www.yarakbirdsofprey.co.uk/js/bootstrap.min.js
http://www.yarakbirdsofprey.co.uk/js/jq … 0.2.min.js
http://www.yarakbirdsofprey.co.uk/js/bootstrap.min.js
I can't hear what I'm looking at.
It's easy to overlook something you're not looking for.

Here's my S-Drive site with
examples of what can be accomplished in VSD.
https://progrower.coffeecup.com/
Here's my CoffeeCup SCCP Shop with examples of what can be done.
https://progrower.coffeecup.com/shop/
This is a site I built for my work.(RSD)
http://esmansgreenhouse.com
This is a site I built for use in my job.(HTML Editor)
https://pestlogbook.com
This is my personal site used for testing and as an easy way to share photos.(RLM imported to RSD)
https://ericrohloff.com
User 2098239 Photo


Registered User
15 posts

Hi Eric, I didnt think there was an issue with those files, i have modified the paths inside the header so have been using those files from inside the /templates/js/ folder..Unless this causes issues i am not aware of this part should be ok..

Hi Steve.. Its the latest build 1.5 (56).
The issue seems to be RLM as the issue happens smack on a breakpoint, but i cant see any differences between before and after the breakpoints..

heres the menu builder sample:
http://www.yarakbirdsofprey.co.uk/yarak-menu3.html

So it would seem its not a menu builder issue, it seems that something in RLM at the breakpoint has changed that hides/breaks the menu output..
Strange, still lost at this point..
Many thanks
Carl
User 187934 Photo


Senior Advisor
18,676 posts

Try giving your menu a unique id and class inside menubuilder and reexport and re add the code to your page.
I can't hear what I'm looking at.
It's easy to overlook something you're not looking for.

Here's my S-Drive site with
examples of what can be accomplished in VSD.
https://progrower.coffeecup.com/
Here's my CoffeeCup SCCP Shop with examples of what can be done.
https://progrower.coffeecup.com/shop/
This is a site I built for my work.(RSD)
http://esmansgreenhouse.com
This is a site I built for use in my job.(HTML Editor)
https://pestlogbook.com
This is my personal site used for testing and as an easy way to share photos.(RLM imported to RSD)
https://ericrohloff.com
User 2098239 Photo


Registered User
15 posts

Hi Eric.
thanks for the suggestion, it didnt seem to fix the issue..I will shortly create a new template just to see if the same menu setup works in a different design..
Its a bootstrap2 theme not a coffeegrinder if that makes any diference..
If i get it working in a fresh template then its something in RLM..

Talk soon
Carl
User 122279 Photo


Senior Advisor
12,468 posts
Online Now

Carl, I haven't checked your site, just the menu. One thing you need to do, is creating a breakpoint at about 890px width and do some editing so that the menu doesn't wrap into two lines. You could e.g. reduce the space between the menu items, or make the text a wee bit smaller, or both.
Ha en riktig god dag!
Inger, Norway
My new honey site, built with RFF: http://www.eikweb.com/horgenhonning/
Component sharing for RFF, RBB, RSD and SD: http://www.eikweb.com/sharing/


User 2098239 Photo


Registered User
15 posts

Hi Inger..Thanks for the input, I have re-visited and added a breakpoint as suggested so the menu doesn't wrap into 2 lines..
The main issue was the problem that the mobile menu didn't appear as it should..

For the moment I found a solution by updating part of the css after all else had loaded in..
I created a file for custom.css and called this last..
The file contained this content..

@CHARSET "ISO-8859-1";
/*@media all and (max-width:979px)*/
.nav-collapse, .collapse.nav-collapse {
overflow: visible;
height: auto;
}

Now the menu resizes and pushes the page down when opened, thus showing the menu as it should..

my "HOME" link in the menu isn't right, this is probably my fault..

all seems better..

Cheers
Carl

Have something to add? We’d love to hear it!
You must have an account to participate. Please Sign In Here, then join the conversation.