No From field in test emails - Post...

User 27149 Photo


Registered User
14 posts

I think that the latest version of RED is not including the FROM field in the email header - at least in the test emails I've sent myself. I haven't yet sent any emails to other recipients. My email client (eM Client) said my test came from nobody@invalid.invalid and I cannot see a From: field in the mail header.

One other point, the client I use on my Android phone (K9mail) when receiving RED V2 emails shows the <![if !mso]> statements within the message. Otherwise the display of the message is fine.

Looking forward to your comments

Peter Oates
User 187934 Photo


Senior Advisor
19,039 posts
Online Now

Hi Peter,
Click on Campaign Setting then Email and see if that's what your looking for.
I can't hear what I'm looking at.
It's easy to overlook something you're not looking for.

This is a site I built for my work.(RSD)
http://esmansgreenhouse.com
This is a site I built for use in my job.(HTML Editor)
https://pestlogbook.com
This is my personal site used for testing and as an easy way to share photos.(RLM imported to RSD)
https://ericrohloff.com
User 27149 Photo


Registered User
14 posts

Hi,

I fill that in fine. I'm not referring to the on screen field within the Campaign Settings. I'm referring to the From: field actually within the header of the email message itself generated by the software. It's only the latest build of RED that seems to omit this - I've looked within messages I sent last month and the field is correctly present.

Peter
User 187934 Photo


Senior Advisor
19,039 posts
Online Now

On the same tab enter the Preheader text.
I can't hear what I'm looking at.
It's easy to overlook something you're not looking for.

This is a site I built for my work.(RSD)
http://esmansgreenhouse.com
This is a site I built for use in my job.(HTML Editor)
https://pestlogbook.com
This is my personal site used for testing and as an easy way to share photos.(RLM imported to RSD)
https://ericrohloff.com
User 27149 Photo


Registered User
14 posts

Yes I have done that. I have completed all 5 fields on that page.
User 103173 Photo


VP of Software Development
0 posts

I just ran a test and it shows for me here:

Return-Path: <XXX@coffeecup.com>
Received: from localhost ([2603:3001:3300:5600:c97f:f91d:521b:edf6])
by smtp.gmail.com with ESMTPSA id l12sm7299139ywh.29.2017.05.30.13.43.10
for <xxx@coffeecup.com>
(version=TLS1_2 cipher=ECDHE-RSA-AES128-GCM-SHA256 bits=128/128);
Tue, 30 May 2017 13:43:10 -0700 (PDT)
Message-ID: <592dd95e.0cad810a.ef7d5.c618@mx.google.com>
Date: Tue, 30 May 2017 13:43:10 -0700 (PDT)
Sender: Scott Swedorski <XXX@coffeecup.com>
From: XXX@coffeecup.com
Reply-To: Scott Swedorski <XXX@coffeecup.com>
To: Swedorski <XXX@coffeecup.com>
Subject: My email Test
MIME-Version: 1.0
Content-Type: multipart/related; boundary=ae6ed41f37d5a0cdaecb6be8117e3125
Content-Transfer-Encoding: 8bit
Learn the essentials with these quick tips for Responsive Site Designer, Responsive Email Designer, Foundation Framer, and the new Bootstrap Builder. You'll be making awesome, code-free responsive websites and newsletters like a boss.
User 27149 Photo


Registered User
14 posts

I've just run another test and attach the email header. All fields in the Email tab of Campaign Settings completed and the Send Email button clicked. I have run this test 5 times over the last 24 hours and always with the same result - no From: field present.
Attachments:
User 103173 Photo


VP of Software Development
0 posts

Peter Oates wrote:
I've just run another test and attach the email header. All fields in the Email tab of Campaign Settings completed and the Send Email button clicked. I have run this test 5 times over the last 24 hours and always with the same result - no From: field present.

Sounds like your email provider or sending provider is stripping it out. I can confirm here that sending it through Gmail and Outlook, the FROM is always there in the headers.
Learn the essentials with these quick tips for Responsive Site Designer, Responsive Email Designer, Foundation Framer, and the new Bootstrap Builder. You'll be making awesome, code-free responsive websites and newsletters like a boss.
User 27149 Photo


Registered User
14 posts

I find this all a bit strange. I have also tested using Thunderbird pasting the HTML from Export into the email body and sending to myself. That message arrived, displayed correctly and included the From: field. So I don't think my provider is stripping the field.

In my original post on this topic I mentioned that my Android email client was displaying "<![if !mso]>" within the displayed RED test message. The test sent via Thunderbird did not. Also strange.

User 103173 Photo


VP of Software Development
0 posts

Peter Oates wrote:
I find this all a bit strange. I have also tested using Thunderbird pasting the HTML from Export into the email body and sending to myself. That message arrived, displayed correctly and included the From: field. So I don't think my provider is stripping the field.

In my original post on this topic I mentioned that my Android email client was displaying "<![if !mso]>" within the displayed RED test message. The test sent via Thunderbird did not. Also strange.


Sending through Thunderbird will take the FROM address in your email client. The displaying of the <![if !mso]> would also indicate a problem with your sending service because if those are appearing, they are making modifications to the markup on sending. You need to make sure they make zero modifications.

Also, under this account I don't show any RED subscriptions or orders for RED v2. Do you have another account with us? If you do have another account, make sure to use the Send Email feature in RED as that will contain the FROM address in the header markup.
Learn the essentials with these quick tips for Responsive Site Designer, Responsive Email Designer, Foundation Framer, and the new Bootstrap Builder. You'll be making awesome, code-free responsive websites and newsletters like a boss.

Have something to add? We’d love to hear it!
You must have an account to participate. Please Sign In Here, then join the conversation.