Wow with Foundation Framer 6 - Page 2

User 2846109 Photo


Ambassador
309 posts
Online Now

Just wanted to throw this out here. If you are going to use the WOW.js for commercial projects you need to purchase a licence for it. So... it's not free to use for paid work, etc.

https://www.uplabs.com/market/license
http://www.pixelandpoly.com/ (built with Bootstrap Builder)
Video Tutorials - https://www.youtube.com/channel/UCQMcF0 … EKA/videos
The Universe from A to Z - https://universeatoz.com/ (built with Foundation Framer)
User 244626 Photo


Registered User
539 posts

Jeff wrote:
Just wanted to throw this out here. If you are going to use the WOW.js for commercial projects you need to purchase a licence for it. So... it's not free to use for paid work, etc.

https://www.uplabs.com/market/license


One could search for the MIT version 1.1.2.
User 2846109 Photo


Ambassador
309 posts
Online Now

wow that's great to know! I found a forked MIT version here: https://github.com/graingert/WOW

Thanks for the info!
http://www.pixelandpoly.com/ (built with Bootstrap Builder)
Video Tutorials - https://www.youtube.com/channel/UCQMcF0 … EKA/videos
The Universe from A to Z - https://universeatoz.com/ (built with Foundation Framer)
User 2846109 Photo


Ambassador
309 posts
Online Now

Does anyone have an idea why the offset works fine with the WOW.js that needs a licence but it doesn't seem to work for me with the MIT version.

Here's the licence version:
https://github.com/matthieua/WOW

Here's the MIT version:
https://github.com/graingert/WOW

I've tried linking to the direct js files and also tried linking to the CDNJS remote files but I can't get the offset to work with the MIT version either way.

I can't seem to see any differences in the scripts that would make a difference. Frustration level 8.7 and rising...

Cheers!
http://www.pixelandpoly.com/ (built with Bootstrap Builder)
Video Tutorials - https://www.youtube.com/channel/UCQMcF0 … EKA/videos
The Universe from A to Z - https://universeatoz.com/ (built with Foundation Framer)
User 244626 Photo


Registered User
539 posts

Jeff wrote:
Does anyone have an idea why the offset works fine with the WOW.js that needs a licence but it doesn't seem to work for me with the MIT version.

Here's the licence version:
https://github.com/matthieua/WOW

Here's the MIT version:
https://github.com/graingert/WOW

I've tried linking to the direct js files and also tried linking to the CDNJS remote files but I can't get the offset to work with the MIT version either way.

I can't seem to see any differences in the scripts that would make a difference. Frustration level 8.7 and rising...

Cheers!


I downloaded that version and did a test with 50 and 500 for offset and it worked.Make sure when adding your resource it comes before initialization of wow.init. I linked to wow.js in dist folder. I did my test with global settings like the first file I uploaded for demo. Comma after offset missing ?
User 2846109 Photo


Ambassador
309 posts
Online Now

Yeah, It's weird. I have a project with the lience wow and it works fine. I then make a copy and update with the MIT versions and none of the offsets work. Nothing else changes so I'm not sure what would go wrong. I link to the new JS script and paste in the new init code in the same place. I'll keep on fooling with it. Thanks for the suggestions!

http://www.pixelandpoly.com/ (built with Bootstrap Builder)
Video Tutorials - https://www.youtube.com/channel/UCQMcF0 … EKA/videos
The Universe from A to Z - https://universeatoz.com/ (built with Foundation Framer)
User 187934 Photo


Senior Advisor
18,025 posts
Online Now

Do we have a link to the page your having issues with?
I can't hear what I'm looking at.
It's easy to overlook something you're not looking for.

Here's my S-Drive site with
examples of what can be accomplished in VSD.
http://progrower.coffeecup.com/
Here's my CoffeeCup SCCP Shop with examples of what can be done.
http://progrower.coffeecup.com/shop/
This is a site I built for my work.(RSD)
http://esmansgreenhouse.com
This is a site I built for use in my job.(HTML Editor)
https://pestlogbook.com
This is my personnel site used for testing and as an easy way to share photos.(RLM imported to RSD)
http://ericrohloff.com
http://ericrohloff.com/property/
User 2846109 Photo


Ambassador
309 posts
Online Now

No, the site isn't live yet. I can see if I can either upload a temp version or recreate the issue on a new 'blank' site. I'll try to get something on Monday.

Thanks!
http://www.pixelandpoly.com/ (built with Bootstrap Builder)
Video Tutorials - https://www.youtube.com/channel/UCQMcF0 … EKA/videos
The Universe from A to Z - https://universeatoz.com/ (built with Foundation Framer)
User 2846109 Photo


Ambassador
309 posts
Online Now

I was able to get it to work when I link to the CDNJS file "https://cdnjs.cloudflare.com/ajax/libs/graingert-wow/1.2.2/wow.min.js" but I when I use a local file it doesn't work.

I've tried putting the local file in the root folder in the resources, in a 'js' folder and also in a new uniquely named folder.

I put the resource link at the top of the resource pane just like the link to the CDNJS is at the top. Nothing else changes.

So, where does everyone put their local js files? in a js folder?

I don't mind using the CDNJS link but it would be nice to know why the local file doesn't work.

thanks again!
http://www.pixelandpoly.com/ (built with Bootstrap Builder)
Video Tutorials - https://www.youtube.com/channel/UCQMcF0 … EKA/videos
The Universe from A to Z - https://universeatoz.com/ (built with Foundation Framer)
User 187934 Photo


Senior Advisor
18,025 posts
Online Now

Can you show us your js link?
Then show us your resource directory structure.
I can't hear what I'm looking at.
It's easy to overlook something you're not looking for.

Here's my S-Drive site with
examples of what can be accomplished in VSD.
http://progrower.coffeecup.com/
Here's my CoffeeCup SCCP Shop with examples of what can be done.
http://progrower.coffeecup.com/shop/
This is a site I built for my work.(RSD)
http://esmansgreenhouse.com
This is a site I built for use in my job.(HTML Editor)
https://pestlogbook.com
This is my personnel site used for testing and as an easy way to share photos.(RLM imported to RSD)
http://ericrohloff.com
http://ericrohloff.com/property/

Have something to add? We’d love to hear it!
You must have an account to participate. Please Sign In Here, then join the conversation.