Color Schemer file access error - Post ID 207113


Registered User
4 posts

Hi

I have just updated my ColorSchemer to build 126 and now find that when I try to exit the program an error box appears with the message "Cannot create file C:\Documents and Settings[myname]\Application Data\CoffeeCup Software\CoffeeCup Color Schemer\Schemer.dat". The program then fails to exit and I am unable to save any of my color schemes.

I am using Windows 8 so was a bit surprised as I thought it should save the file to C:\Users[myname]\AppData\Roaming\CoffeeCup Software\CoffeeCup Color Schemer\Schemer.dat.

Can you throw any light on this?

Kelvin Seacombe


Senior Advisor
2,942 posts

Don't know about Win8 yet, but, are you running the program as 'Administrator' ? That seems to fix many issues in newer windows versions. Just a thought...
Graphics for the web, email, blogs and more!
-------------------------------------
http://sadduck.com


Registered User
10,951 posts

Hiya Kelvin,

Have you tried uninstalling and reinstalling it? Also try setting the program to run as Admin:

1. Right click the shortcut you use to start the program and choose Properties on the menu that pops up.
2. Go to the Compatibilities tab on that next window.
3. Put a check in the box at the bottom to Run as Administrator and say OK or Save.

Now try running the program and see if that helps. Not sure it will help with this issue, but worth a try before reinstalling it. Be sure to Uninstall it before Reinstalling it so it's a clean install also.


Registered User
4 posts

I have now tried a clean install, as well as 'Running as Administrator' but still no good!.
However if I log onto Windows using the Administrator account and run ColorSchemer then all is OK.

Oh the joys of Windows User Account Control.


Registered User
10,951 posts

hmm, that's pretty strange, usually if it runs well under an Admin account, giving it admin privs will fix the problem. What version of windows are you on? Have you tried running with a different Windows version compatibility setting?


Registered User
4 posts

I'm using Windows 8 Pro. I've tried running under the WinXP and Win7 compatibility modes to no avail. When I was running Windows 7 Ultimate OS the problem wasn't apparent.


Registered User
10,951 posts

I would suggest opening a support ticket Kelvin and hopefully one of the CC staff can help work that out. I'm using Windows 8 Pro also and came from Windows 7 Ultimate too and have had no issues with that program or any other CC ones for that matter. Not sure what else to suggest here.


VP of Software Development
49,402 posts

It sounds to me like the account you are logged in as may not have full admin access. That would explain why logging in as the Admin account worked. You may want to switch over to the other account and use that one instead. Probably not the perfect solution, but if you already know that fixes it, I say go with it. ;)
Learn the essentials with these quick tips for Responsive Site Designer, Responsive Email Designer, Foundation Framer, and the new Bootstrap Builder. You'll be making awesome, code-free responsive websites and newsletters like a boss.


Senior Advisor
2,942 posts

One other question, when you initially installed the application, did you install as 'administrator'?
If not, you might try uninstalling, then right click the install file and select 'run as administrator' and let it install. That works for win7 on some things, not sure about win8.

Graphics for the web, email, blogs and more!
-------------------------------------
http://sadduck.com


Registered User
4 posts

Thanks Gunsmoke.
I did the initial install under the Administrator account.

I have just discovered that running ColorSchemer under my wife's account work fine as well. We both have Users and Admistrators privileges so I think I will just try re-creating my account and hope the problem goes away.

Have something to add? We’d love to hear it!
You must have an account to participate. Please Sign In Here, then join the conversation.