Php 7.2

User 60894 Photo


Registered User
2 posts

Due to security reasons our hosting provider is shutting down previous versions of PHP (e.g. 5.6, 7.0 and 7.1) .
Only PHP version 7.2 is supported.

When using the php 7.2 we are hitting on this error when using a defined form.

Your form could not be submitted for the following reason(s):
Warning: [ err 2/line 277/mailer.cls.php] Use of undefined constant writeErrorLog - assumed 'writeErrorLog' (this will throw an Error in a future version of PHP)

Any idea?
And does WFB 2.9 Build 5519 fully supports PHP 7.2?

Thx
With kind regards,

Bas Grabowsky
User 187934 Photo


Senior Advisor
18,676 posts

Hi Bas,
It should support it.
Can you share a link to your form so we can check it out.
I can't hear what I'm looking at.
It's easy to overlook something you're not looking for.

Here's my S-Drive site with
examples of what can be accomplished in VSD.
https://progrower.coffeecup.com/
Here's my CoffeeCup SCCP Shop with examples of what can be done.
https://progrower.coffeecup.com/shop/
This is a site I built for my work.(RSD)
http://esmansgreenhouse.com
This is a site I built for use in my job.(HTML Editor)
https://pestlogbook.com
This is my personal site used for testing and as an easy way to share photos.(RLM imported to RSD)
https://ericrohloff.com
User 60894 Photo


Registered User
2 posts

Hi Eric. Currently I have a support open.
Of looks like some PHP files still support deprecated features. When running on a PHP7.2 servers of is an issue.

The developers from Coffeecup are looking at it.

Thx

E.g.
File = fbapp/php/config.inc.php
Line 64
Error message:
Deprecated: __autoload() is deprecated, use spl_autoload_register() instead
With kind regards,

Bas Grabowsky
User 447635 Photo


Registered User
2 posts

I have the same problem. I have removed the Web Form and just put an email link for now. Better than a broken page.
Larry
User 2863844 Photo


Registered User
11 posts

Any news about php 7.2?

I was recomended to change user.cfg.pgp and change to localhost.
$user_config['mailer']['service'] = 'localhost';
//$user_config['mailer']['service'] = 'smtp';

This makes the form work without error messages, BUT it wont send any mail...

So...
I changed to PHP 5.6, but in mid december I'll be forced over to php7.2.

Any ideas?
User 187934 Photo


Senior Advisor
18,676 posts

Hi Frank,
I would open a support topic and ask CC what you can do about the issue.
https://www.coffeecup.com/help/myroom/opentopic/
Post back when you get an answer.
I can't hear what I'm looking at.
It's easy to overlook something you're not looking for.

Here's my S-Drive site with
examples of what can be accomplished in VSD.
https://progrower.coffeecup.com/
Here's my CoffeeCup SCCP Shop with examples of what can be done.
https://progrower.coffeecup.com/shop/
This is a site I built for my work.(RSD)
http://esmansgreenhouse.com
This is a site I built for use in my job.(HTML Editor)
https://pestlogbook.com
This is my personal site used for testing and as an easy way to share photos.(RLM imported to RSD)
https://ericrohloff.com
User 2863844 Photo


Registered User
11 posts

I have a support topic but all I get is the advice to chance from smtp to localhost.
They are working on it, but in 10 days I'm forced over to 7.2.....

I'm opening a support ticket with my webhost too. They are pretty good att helping.. ;)

User 2863844 Photo


Registered User
11 posts

Looks like we found the error.

My webhost checked the script and found the following error:

Path: /common/fbapp/php
File: mailer.cls.php
Line: 277
$mail->Debugoutput = writeErrorLog;

Change to:
$mail->Debugoutput = 'writeErrorLog';

It's missing : ' '

In program folder do the same change.
Path: /program files/WebFormBuilder/library/server-scripts/fbapp/php/
File: mailer.cls.php
Line: 277
Change to: $mail->Debugoutput = 'writeErrorLog';

This will update mailer.cls.php in your webform folder before export.

I have tested the script with my own smtp.
No error messages and mail is sendt.




User 187934 Photo


Senior Advisor
18,676 posts

What version of the Form Builder are you using? My mailer.cls.php doesn't have that.
I can't hear what I'm looking at.
It's easy to overlook something you're not looking for.

Here's my S-Drive site with
examples of what can be accomplished in VSD.
https://progrower.coffeecup.com/
Here's my CoffeeCup SCCP Shop with examples of what can be done.
https://progrower.coffeecup.com/shop/
This is a site I built for my work.(RSD)
http://esmansgreenhouse.com
This is a site I built for use in my job.(HTML Editor)
https://pestlogbook.com
This is my personal site used for testing and as an easy way to share photos.(RLM imported to RSD)
https://ericrohloff.com
User 2863844 Photo


Registered User
11 posts

I'm using 2.9 Build 5519

Bas had the same problem as me and the text gives us the answer.

Use of undefined constant writeErrorLog - assumed 'writeErrorLog'
It says that its expecting 'writeErrorLog' not writeErrorLog. Its just the ' and ' that is missing.

What error did you get in 7.2 when using smtp server?
I don't Think 7.2 supports localhost as mailserver anymore.


Have something to add? We’d love to hear it!
You must have an account to participate. Please Sign In Here, then join the conversation.