OnMouseOver in Image Map

User 2463866 Photo


Registered User
2 posts

I bought Image Mapper this morning just for one feature I like, and I can't get it to work on an existing map. I just want hover text to appear over the different regions, and Dreamweaver doesn't give me an easy way to do that. My problem has two parts.

1. I open my existing map from http://www.rane.com/where.htm. My original working map has 16 regions, all visible and editable in Dreamweaver, but Image Mapper only shows three of them: Marshank, Pro Tech, and Marketing Concepts. I've compared the region code from the non-loading areas to the loading areas and don't see the difference. How can I get Image Mapper to recognize all the existing regions?

2. The browser preview in Image Mapper works right with the name showing on hover. I thought I could at least learn the code that Image Mapper is putting in for the MouseOver Text to work (in Area Properties). It adds the code "OnMouseOver="window.status='Marshank'; return true" OnMouseOut="window.status=''; return true". But when I put this in Dreamweaver and upload, nothing happens. Is there a conflict with my current behavior that opens the panels below?

Any help is appreciated. Thanks.
User 103173 Photo


VP of Software Development
0 posts

1. I open my existing map from http://www.rane.com/where.htm. My original working map has 16 regions, all visible and editable in Dreamweaver, but Image Mapper only shows three of them: Marshank, Pro Tech, and Marketing Concepts. I've compared the region code from the non-loading areas to the loading areas and don't see the difference. How can I get Image Mapper to recognize all the existing regions?


I get a 404 error for that link Jeff. Can you confirm the URL.

2. The browser preview in Image Mapper works right with the name showing on hover. I thought I could at least learn the code that Image Mapper is putting in for the MouseOver Text to work (in Area Properties). It adds the code "OnMouseOver="window.status='Marshank'; return true" OnMouseOut="window.status=''; return true". But when I put this in Dreamweaver and upload, nothing happens. Is there a conflict with my current behavior that opens the panels below?

Sounds like Dreamweaver is modifying the markup. How does it work if you upload instead with an FTP client?
Learn the essentials with these quick tips for Responsive Site Designer, Responsive Email Designer, Foundation Framer, and the new Bootstrap Builder. You'll be making awesome, code-free responsive websites and newsletters like a boss.
User 2463866 Photo


Registered User
2 posts

Sorry, should have pasted the URL.
http://www.rane.com/where.html
User 187934 Photo


Senior Advisor
18,132 posts

Just helped another user for the same thing.
This approach works with pc and mobile devices.
http://www.coffeecup.com/forums/image-m … nd-iphone/
I can't hear what I'm looking at.
It's easy to overlook something you're not looking for.

Here's my S-Drive site with
examples of what can be accomplished in VSD.
http://progrower.coffeecup.com/
Here's my CoffeeCup SCCP Shop with examples of what can be done.
http://progrower.coffeecup.com/shop/
This is a site I built for my work.(RSD)
http://esmansgreenhouse.com
This is a site I built for use in my job.(HTML Editor)
https://pestlogbook.com
This is my personnel site used for testing and as an easy way to share photos.(RLM imported to RSD)
http://ericrohloff.com
http://ericrohloff.com/property/

Have something to add? We’d love to hear it!
You must have an account to participate. Please Sign In Here, then join the conversation.