HTML Editor - CSS Validator Hangs -...

User 122279 Photo

Senior Advisor
13,261 posts

Going back to the start of this thread:
Norris Girling wrote:
Using the CSS validator on a CSS file process it but fails to open a browser window as the HTML validator on the validator site. Instead the validator pop up window remains and the whole program hangs, the only way out is to kill the process. Happen when other html pages are open.

I understand this as you are trying to validate a css file using the 'Validate css' found under the 'Document' menu, and the process doesn't open a browser window. Which of them hang, the html Editor or the browser?

I have tried having my html extension associated with my default browser (Ffx) and with the Editor itself. In the former case the browser opens without problem, in the latter case the Editor opens the code window, also without problems, and the page can be previewed just like any other page. I have two or three html pages open and one css file. No problem at this end with either, and I don't recall having had such problems earlier. The css file I tested this with is not particularly complex, but it validated. Is your file possibly very long, very complex and has a lot of errors?
Ha en riktig god dag!
Inger, Norway
My new honey site, built with RFF:
Component sharing for RFF, RBB, RSD and SD:

User 184085 Photo

1,707 posts

The editor itself hangs, not the browser. Yes trying to validate the css from the documents menu.
Volunteering to help :)
My HTML play area
User 187934 Photo

Senior Advisor
19,238 posts

I'm trying to replicate consistently.;)
I can't hear what I'm looking at.
It's easy to overlook something you're not looking for.

This is a site I built for my work.(RSD)
This is a site I built for use in my job.(HTML Editor)
This is my personal site used for testing and as an easy way to share photos.(RLM imported to RSD)
User 2016442 Photo

Registered User
7 posts

Hi, I've just accessed the Validate CSS from the Documents menu and I'm getting the same. I thought it was the old HTML version 12+ that thad the problem but it's the new one too (I only purchased it from CC last week). If the Validate CSS comes up with errors, I get a W3C window similar to the HTML one. When I have corrected any errors and tried to validate again, I get a small box in the centre of the CC screen which says CSS validation done and the animations continue working but I can't close it or cancel it, nor can I close HTML Editor in the normal way. I have to use Task Manager and 'end Task'. Has anyone found a solution yet?
User 2147626 Photo

2,942 posts

I would go to your account and open a support topic for CoffeeCup so the gurus can look into it. Just click on your name at the top right, then come down to 'Your Support Room' and open a topic. There are several threads about various validation hangups and I think CC aught to be looking into this. Make sure you give them all the information you can. Such as Operating system, browser, laptop or desktop, screen size, exact error, etc...

If/when you get an answer, please post back here and let us know what they/you found out. Thanks. :cool:
Graphics for the web, email, blogs and more!
User 2016442 Photo

Registered User
7 posts

Thanks Gunsmoke, I did that and here is the reply: "This can happen even if you are running as an Administrator, and it is caused by Windows very strict security settings.

To fix this, right-click the HTML Editor shortcut icon, and select Run as Administrator. This should properly launch the HTML Editor for you. If it does, then great! You can continue to launch the program in this way, or you can go a step further and configure the shortcut to always run as administrator. Here's how:

1. Right-click the shortcut icon and click Properties.
2. Click the Compatibility tab.
3. Put a check mark by Run This Program as an Administrator.
4. Put a check mark by Run This Program in Compatibility Mode For: and ensure Windows XP Pro Service Pack 2 is selected.
5. Click OK.

If you continue having problems you may also need to set the application as an exception to Windows Data Execution Prevention (DEP) feature. Normally if this is the culprit, you'll get a little bubble along the taskbar notifying you, which will allow you to set the offender as an exception.

One last option that could be the cause of this, and related to the DEP feature, is User Account Controls. This is the large window that appears in Vista asking you to "Allow" or "Deny" access to functions within programs. You can turn this off within your Control Panel > User Accounts window, along the left-hand pane.

All three options let you control your system exactly how you want and give you full access to do/run anything on the computer."
Run as adminstrator worked for my Vista laptop, but didn't work on my Windows 7 PC, I haven't tried the other options yet, they seem a bit too technical for me so I've been using the link direct to W3C which someone gave in another thread.
User 2147626 Photo

2,942 posts

Well, sorry it wasn't a 100% fix yet, but thanks for posting back and letting us know. Good luck to you. :cool:
Graphics for the web, email, blogs and more!
User 2822499 Photo

Registered User
1 post

Still have the same problem with CSS validation hanging. Tried the run as administrator and that had no positive effect.
User 103173 Photo

VP of Software Development
0 posts

Stephan Arndt wrote:
Still have the same problem with CSS validation hanging. Tried the run as administrator and that had no positive effect.

What version/build of the HTML Editor are you using Stephan?
Learn the essentials with these quick tips for Responsive Site Designer, Responsive Email Designer, Foundation Framer, and the new Bootstrap Builder. You'll be making awesome, code-free responsive websites and newsletters like a boss.
User 2122179 Photo

Registered User
3 posts


Still hangs up in WC3 CSS Validator. Editor Version 15, just a sec, got to kill the process to get the about. Ok version 15.769

Don't have the problem with HTMLpad 2015 or Brackets. Just don't have a clue. Validator starts, says it is done, no chrome tab opened like the HTML validator. CSS is Coffee CSS from menu builder is version 12. Tab is only CSS.

Can't cancel, program frozen. Have to fire up process explorer, find the editor and kill it.

So no joy!

Have something to add? We’d love to hear it!
You must have an account to participate. Please Sign In Here, then join the conversation.