How to change the default browser

User 2585474 Photo


Registered User
1 post

When I want to test the HTML page with the default browser, I click Tools and then select "Test with default browser". However, the browser used to text the HTML page is not my default browser. My default browser is IE 10, and the browser actually used for the test is Chrome. How do I change this so when I select "Test with default browser", your software will use IE 10 and not Chrome. When I check my OS setting, it says that IE 10 is my default browser. I never made any change to choose Chrome as my default browser. In fact when I bring up Chrome, it tells me it is not my default browser. I am enjoying your software. Thanks for your help. John Cordero in Las Vegas.
User 38401 Photo


Registered User
10,951 posts

Set the default browser in the HTML Editor settings. Then it will choose that default browser.
User 122279 Photo


Senior Advisor
12,133 posts

Or right'click on a html file (when it is on your desktop or in a folder), choose properties and change the file association where it says 'Open with' to your default browser.
Ha en riktig god dag!
Inger, Norway
My new honey site, built with RFF: http://www.eikweb.com/horgenhonning/
Component sharing for RFF, RBB, RSD and SD: http://www.eikweb.com/sharing/


User 69840 Photo


Registered User
49 posts

When viewing any html file with coffeecup html by selecting view with default browser, it always uses Opera. IE is my default browser. I have check settings in both browsers to make sure. I see no way of making IE the default browser within CoffeeCup HTML v12.9 b714.
I reinstalled Opera 2 days ago and made sure IE was set to default after install.
IDEAS??
BTW if I check properties on any html file saved, it says IE is default and if I double click the said html file, it opens in IE. Just wont with coffeecup.
User 69840 Photo


Registered User
49 posts

Here is proof Opera isn't default
Attachments:
User 187934 Photo


Senior Advisor
18,337 posts
Online Now

What icon do html files have when you browse your files with file explorer?
I can't hear what I'm looking at.
It's easy to overlook something you're not looking for.

Here's my S-Drive site with
examples of what can be accomplished in VSD.
http://progrower.coffeecup.com/
Here's my CoffeeCup SCCP Shop with examples of what can be done.
http://progrower.coffeecup.com/shop/
This is a site I built for my work.(RSD)
http://esmansgreenhouse.com
This is a site I built for use in my job.(HTML Editor)
https://pestlogbook.com
This is my personal site used for testing and as an easy way to share photos.(RLM imported to RSD)
https://ericrohloff.com
User 271657 Photo


Senior Advisor
3,816 posts

Within the Editor, set your browser choices here:
Tools > Preferences > Browser Testing
The default browser choice is a version of IE*.

When you click the Preview button, you'll see Test With Default Browser (some version of IE), followed by
Test With Chrome <<<Your chosen browsers listed under the default browser
Test With Firefox
and so on...

I have FF set as default for my computer, and I see when I click the *Test w Default, it does open in FF rather than IE. :o
I have IE11 as one of the browser choices though, so never use the default option, I just click the browser name that I want to preview with.
I would just put IE as the first of your browser choices after default. (unless someone else has a better idea :D)
I love deadlines. I like the whooshing sound they make as they fly by. (Douglas Adams)
https://www.callendales.com
User 271657 Photo


Senior Advisor
3,816 posts

Try Eric's idea – set html files to open with IE from within the Default Programs panel.
Mine is set to open with FF, so I guess it over-rides the default in the Editor.
I love deadlines. I like the whooshing sound they make as they fly by. (Douglas Adams)
https://www.callendales.com
User 69840 Photo


Registered User
49 posts

Eric, the icon shows IE.
I am no newbie to computers or web designing, just cant figure out this problem LOL.
I have an extensive knowledge in this area.
And here is a screenshot of browser settings.
Attachments:
User 103173 Photo


VP of Software Development
0 posts

Best way I have found to fix that is make one browser your new default and then switch back to th other browser and make it the default browser again. Seems you have some out of sync registry keys in your registry.
Learn the essentials with these quick tips for Responsive Site Designer, Responsive Email Designer, Foundation Framer, and the new Bootstrap Builder. You'll be making awesome, code-free responsive websites and newsletters like a boss.

Have something to add? We’d love to hear it!
You must have an account to participate. Please Sign In Here, then join the conversation.