Form Builder and PHP 7.4 and above -...

User 187934 Photo


Senior Advisor
19,982 posts

Lloyd Harrington wrote:
I just had to downgrade the php version from 8 to 7.4 as 9 forms on various sites all stopped working. Reverting back all forms are working again. The error is in line 64 of config.inc.php on autoload.

Lloyd

Yes, there 's an issue with php V8 on the Form Builder. Hoping CC has an option soon.
I can't hear what I'm looking at.
It's easy to overlook something you're not looking for.

This is a site I built for my work.(RSD)
http://esmansgreenhouse.com
This is a site I built for use in my job.(HTML Editor)
https://pestlogbook.com
This is my personal site used for testing and as an easy way to share photos.(RLM imported to RSD)
https://ericrohloff.com
User 373703 Photo


Registered User
70 posts

This post was started in February, it's now mid-September and I still don't see any answers other than "they are working on it". My hosting company has already sent a notice that they will be moving to 8.1 as of December.

Hopefully, they are getting close,
Lloyd
User 2622524 Photo


Registered User
81 posts

Lloyd Harrington wrote:
This post was started in February, it's now mid-September and I still don't see any answers other than "they are working on it". My hosting company has already sent a notice that they will be moving to 8.1 as of December.

Hopefully, they are getting close,
Lloyd


I'm also concerned about this, I have contacted Coffeecup directly and this is the reply I got from Suzanne Norvell (Sales & Support Manager)

"Hello Chris,

We are working on an update for the Web Form Builder to run on PHP 8. We actually hired a new PHP programmer to help with the task. However, we don't have an official release date when the project will be finished. Unfortunately, I don't think it will be ready by early October.

As a work around, you could upload your files to S-Drive and paste the embed code into your website."


I hope the Coffeecup development team will deliver soon, else I'm going to have many upset customers should their forms stop working when my host changes to PHP8.X

Coffeecup suggest using their S-Drive, sadly there is a cost involved and at this stage I cannot afford it due to the number of websites involved.
User 486215 Photo


Registered User
79 posts

Thanks for the info in this thread, guys. I found that a long-time form on a client's website had suddenly disappeared. I was able to set the PHP version back to 7.4 from the 8.1 that the host provider had automatically upgraded. I finally found it was that simple after spending a great deal of time trying to figure out what was wrong!
User 2287960 Photo


Ambassador
573 posts

Web Form Builder v 2.10 Build 5575

Just changed hosting on a WP site. Form works ok on PHP 7.4 but does not display on PHP 8.

So I have the same problem.

Keith

Have something to add? We’d love to hear it!
You must have an account to participate. Please Sign In Here, then join the conversation.