Form Builder and PHP 7.4 and above

User 2592413 Photo


Registered User
5 posts

Greetings,

Host is upgrading PHP (Ugh) again. 7.3 soon to be deprecated, urging upgrade to 7.4 and even higher versions. Does anyone anticipate a problem with form designer working on 7.4 or even 8.0 ? The form is the only PHP i used for my site and payments must be made to gain access to the form so its a real concern. Thanks!
User 187934 Photo


Senior Advisor
19,948 posts

Hi Marley,
I assume you actually mean Form Builder as Form Designer doesn't have any php scripts tied to it.
Who's your host? I have Bluehost and upgraded my site to php version 7.4 and my forms seem to work fine.
I can't hear what I'm looking at.
It's easy to overlook something you're not looking for.

This is a site I built for my work.(RSD)
http://esmansgreenhouse.com
This is a site I built for use in my job.(HTML Editor)
https://pestlogbook.com
This is my personal site used for testing and as an easy way to share photos.(RLM imported to RSD)
https://ericrohloff.com
User 2592413 Photo


Registered User
5 posts

Hi Eric ,,

Opps, my bad. I am in the wrong forum. yes. I was referring to from builder. I have 2.9 5557, well, that is good to know. Yes, Bluehost and Bluehost is upgrading again 8.0 and above and just trying to avoid any problems before they arise.
User 187934 Photo


Senior Advisor
19,948 posts

You can set which version your using. I was on 7.3 on all of my domains but switched one of them to 7.4.
I can't hear what I'm looking at.
It's easy to overlook something you're not looking for.

This is a site I built for my work.(RSD)
http://esmansgreenhouse.com
This is a site I built for use in my job.(HTML Editor)
https://pestlogbook.com
This is my personal site used for testing and as an easy way to share photos.(RLM imported to RSD)
https://ericrohloff.com
User 2592413 Photo


Registered User
5 posts

I take it the 7.4 worked? i am going to wait until Bluehost finishes the upgrade Wednesday Feb 23rd and see what choices are still available. I have no problem with 7.3 but I was apprehensive about newer versions and did not know what to expect. Without the forms, my website is toast because that is a big part of the income. Anyway, thanks for moving the thread to the correct category! :)
User 187934 Photo


Senior Advisor
19,948 posts

Did you get an email that stated they were going to 8?
I can't hear what I'm looking at.
It's easy to overlook something you're not looking for.

This is a site I built for my work.(RSD)
http://esmansgreenhouse.com
This is a site I built for use in my job.(HTML Editor)
https://pestlogbook.com
This is my personal site used for testing and as an easy way to share photos.(RLM imported to RSD)
https://ericrohloff.com
User 2592413 Photo


Registered User
5 posts

Okay, just as I feared. Bluehost updated PHP to 8.0 and I immediately started getting emails from customers that they paid but the form was blank. Without haste I went to the C-panel and changed all domains to php7.3 but the from is still not working, just the html comes up but not the from.
User 2592413 Photo


Registered User
5 posts

Okay, I am back, all resolved FOR NOW. Apparently it just took about 20 minutes for the change to propagate. I was in panic mode because I changed the domains back to 7.3 but a check of the phpinfo.php was still showing 8.0. I put in a call to bluehost and were backed up and the change took place before they returned my call. So, everything is good for now but I fear we are going to need a coffee cup form upgrade as it will only be a matter of time until we are forced up to 8.0 and it definitely does not work with 8.0. 7.4 is still available but I haven't tried that yet, something to test in the wee hours when no one is using the site. Can anyone say if coffee cup will be upgrading the form builder at some point to work with higher versions. I am happy to purchase the upgrade I just need to to work :)
User 187934 Photo


Senior Advisor
19,948 posts

I haven't tested all of my forms yet but I'm on php version 8 and the few I tested worked fine. What kind of error were you getting on the host?
I can't hear what I'm looking at.
It's easy to overlook something you're not looking for.

This is a site I built for my work.(RSD)
http://esmansgreenhouse.com
This is a site I built for use in my job.(HTML Editor)
https://pestlogbook.com
This is my personal site used for testing and as an easy way to share photos.(RLM imported to RSD)
https://ericrohloff.com
User 373703 Photo


Registered User
69 posts

I just had to downgrade the php version from 8 to 7.4 as 9 forms on various sites all stopped working. Reverting back all forms are working again. The error is in line 64 of config.inc.php on autoload.

Lloyd

Have something to add? We’d love to hear it!
You must have an account to participate. Please Sign In Here, then join the conversation.