Using float to wrap text - Post ID...

User 2220522 Photo


Registered User
11 posts

Another newbie question:

I have coded floats before, but I can't seem to get them to work in SD. I have an image where I want to have some text to its right. I assigned a float left to the image, but the text continues to display directly under the image. The container is wide enough for both the image and text. What am i doing wrong?

Also, I have several small images that I want to go on a line. I assigned an inline property to them, but they continue to stack.

Any help would be appreciated.
User 2699991 Photo


Registered User
1,693 posts
Online Now

Marty wrote:
Another newbie question:

I have coded floats before, but I can't seem to get them to work in SD. I have an image where I want to have some text to its right. I assigned a float left to the image, but the text continues to display directly under the image. The container is wide enough for both the image and text. What am i doing wrong?

Also, I have several small images that I want to go on a line. I assigned an inline property to them, but they continue to stack.

Any help would be appreciated.

The container has to be set to position: display= block
the image has to be the first element in the container (go to inspector & move image to above text if not already) set the clear for the image to left. If all that is already done then I am lost too.
I have several small images that I want to go on a line. I assigned an inline property to them, but they continue to stack.
are they in a container also if so set the container to position: display = flex
direction = row ,
wrap = wrap .(adjust image width as appropriate for breakpoints so that they stack at lower views, & go to row at larger views)
Justify = either space between or space around (your choice as to how you want the spacing between them to be)
Items = center, or flex start (again depends on how you want images to appear
The Sky Is A big Empty Space : But There Is No Room For Error
website https://rsdtutorials.com
User 2220522 Photo


Registered User
11 posts

Thanks a million Wayan. It was the display:block for the container that made it work.

Have something to add? We’d love to hear it!
You must have an account to participate. Please Sign In Here, then join the conversation.