Unable to change image in a container

User 2929204 Photo


Registered User
65 posts

Hi,

Maybe this has been posted before but I can't find anything...

I am trying to swap an image from a container (Tera Template, I think ????) and I click on the Container>Design>New Image> and load the new image but it doesn't change on RSD. I know the image is there somewhere because when I click between Grid, Flex, Block, my image momentarily appears and then the original replaces it and stays there.

I've attached an image of the container of the template as maybe this will help in pinpointing the issue and the template I'm using.

Thanks, Maz
Attachments:
User 2929204 Photo


Registered User
65 posts

My apologies... I attached the wrong image in the original post...

As you can see, I have the image file added, but the original image of the people at the desk remains.
Attachments:
User 122279 Photo


Senior Advisor
13,727 posts

Are you changing a background image or a foreground one? The procedure you describe in your first post is how to change a background image. To change a foreground image, open the Element pane with the picture selected and see the top part there.
Ha en riktig god dag!
Inger, Norway
This site was made before we were able to create components through the app:
Component sharing for RFF, RBB, RSD and SD: https://eikweb.com/sharing/
My work in progress right now:
Components for the same as above + HTML Editor: https://mock-up.coffeecup.com


User 2699991 Photo


Registered User
3,700 posts
Online Now

Maz wrote:
My apologies... I attached the wrong image in the original post...

As you can see, I have the image file added, but the original image of the people at the desk remains.


You have all breakpoints disabled you need set breakpoints to default

The Help You Need: When You Need It The Most
Website Design & Development
Website Renovations
Wayans' Theme Park
Watch Listen & Learn Video Tutorials
User 379556 Photo


Registered User
1,241 posts

I'm wondering whether the version of SD/RSD being used to change that background picture wouldn't accept an image name with a space in it. It might be worth changing the name to 'tarot-1.jpg' to see whether it works then. Double-clicking on the image in the Project Resources should allow editing of the name.

Frank
User 2929204 Photo


Registered User
65 posts

Thanks for the response.

I was in such a rush that what I did was to replace the image in the folder. I know that was cheating but I'll check what you suggested.

I've finally completed my first website and I'm struggling to upload it to an empty domain I have... I'm going to post in a separate thread for that probably after I speak to my hosting providers.

Thanks, Maz
User 2929204 Photo


Registered User
65 posts

Hi there again,

I'm updating the website and still, when i add a b/g image, the container doesn't update with the picture. All I get is 'online image'

The second image is what my settings/image parameters are in RSD so the image is there, but when I preview it, it's blank.

The advice above saying to click on the container and then elements pane doesn't help as there's nothing to add/change in that screen.
Attachments:
User 2699991 Photo


Registered User
3,700 posts
Online Now

Maz wrote:
Hi there again,

I'm updating the website and still, when i add a b/g image, the container doesn't update with the picture. All I get is 'online image'

The second image is what my settings/image parameters are in RSD so the image is there, but when I preview it, it's blank.

The advice above saying to click on the container and then elements pane doesn't help as there's nothing to add/change in that screen.


It is very difficult to see what the problem is from an image

try this first
select the container
go over to the inspector pane
check to see if it has an ID (the ID name will be in orange, the container class name will be in blue

if it has an ID then you need to go to the tab styles then down to the section "apply Styles, open the dropdawn and choose "apply to this elements ID only
then to the Design section delete the background image (if any) and then insert a new background image (choose the one you want

if that fails
then you will really need send the project file for us to see whats going on

if its too large to post here
dropbox it and give us the link

The Help You Need: When You Need It The Most
Website Design & Development
Website Renovations
Wayans' Theme Park
Watch Listen & Learn Video Tutorials
User 2929204 Photo


Registered User
65 posts

Hi Wayan,

Thanks for your reply...

Yes, all sorted. Thanks for that, I adjusted as you said and also changed breakpoints set to all widths just in case there was an issue there.

It's now displaying correctly.


Thanks, Maz


Have something to add? We’d love to hear it!
You must have an account to participate. Please Sign In Here, then join the conversation.