The Cpanel's AutoSSL certificate

User 2823310 Photo


Registered User
312 posts

I'm not an authority on this by any means but if you have recieved the email
AutoSSL certificate installed
from Cpanel you can now change your site over to a secure https link.

To check it click on your site link and change the http to https so if your site is domain.com just put in https://domain.com and you should see the secure connection lock icon in your browsers address bar. Then go through it to make sure all your links are working like they should.

Then you add a redirect using .htaccess, this how you do that.
Open notepad (not wordpad it has to be plain text) and paste this:
RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule (.*) https://%{SERVER_NAME}/$1 [R=301,L]
This type of redirect will also catch queries with no specified URLs from the website, for example if a user is trying to access a page, like for example: http://domain.com/page1.html will be redirected to: https://domain.com/page1.html
SAVE AS: .htaccess
On your computer it'll say .htaccess.txt - notepad needs that .txt extension
FTP that to your ROOT DIRECTORY, that is where all your website files and folders are.
Once there use the FTP client to rename it to just be .htaccess
A NOTE:
As a configuration file, .htaccess is very powerful. Even the slightest syntax error (like a missing space) can result in your content not displaying correctly or at all.
ALSO
Since .htaccess is a hidden system file, please make sure your FTP client is configured to show hidden files. This is usually an option in the program's preferences/options.

Now you need to update your sitemap.xml <url> <loc> to https and delete the old or just edit it online with your ftp client plus if you use a schema on your pages update those.

Once that's all done in Google webmaster you actually need to add a new property to search console by clicking on the "add a property" button and adding the full url. https://www.domain.com and https://domain.com
Google advises you add all four properties: https://www.domain.com https://domain.com http://domain.com and http://www.domain.com
Then you can set the prefered domain.
Google Analytics has a simple way of updating the site with a drop-down box that contains http & https.

There can be more to it, but that's it simplified.
You can always do a search on it for more info.
User 2823310 Photo


Registered User
312 posts

Just to let you know I've switched over an old site of mine to a responsive RSD, and added the Cpanel SSL certificate to it.
https://kingofcrown.com/
That uses the 301 redirect from http://kingofcrown.com/ that I showed you above. It's not too hard to do, it's free and it auto renews so that's neat. Plus I checked it out and it received a A- which is good.

You may already have it available on your Cpanel, you can also check with your host some have it so you can turn it on. I personally received an email right from Cpanel for all of my sites, which I thought was cool.

I'll let you know in a couple of months how it effects rank, since google says they are going to "strengthen" https sites.
User 2823310 Photo


Registered User
312 posts

Okay so the update after 2 months:

With the changes we requested for the images updates in RSD and adding the https I've re-captured my top ranking for local for the searches I was after.

One note on these when you end up with so many links in your google search console.
Even with the re-direct and setting the site setting preference from www.kingofcrown.com to kingofcrown.com for example
I also had to add a rel="canonical" link in the HEADER on each page... so the index got:
<link rel="canonical" href="https://kingofcrown.com/index.html" />
for example and you do that for every page with it's specific link.

What that does is tell search to use your https for your console results. With the 4 links now in there without the rel= link it may use the old http link. So as with most hosts you get the duplicated www's and this way it should go into all those and fix that issue.
User 2765857 Photo


Registered User
480 posts

Alter Eagle - Thanks for update info on this I was not sure about the "canonical" and correct way to implement on pages. You explained what I needed.
Ray
Ray aka Kreations
Since 1994 Chocolate bar wrappers for all occasions.
https://www.kreationspecialties.com/index.htm
Since 1972 helping clients help "Discover Their Dream Vacation"
www.kstravelnj.com
User 2800147 Photo


Registered User
62 posts

Hello Alter Eagle,

I wonder if you can offer a solution for issues changing a domain over to https.

At this point I can redirect the jewelry-tutorials.com to https, but all the images are missing.

It could be due to the images being hosted on site. The website was built with RSD v1.5 which require fixed url's ie. http://jewelry-tutorials.com/images/etcetera.jpg

I have tried several permutations including doing a redirect on the folder "images".

That did not work. (At this point I reset the .htaccess file to the original, so at least the website can display correctly under http)

How did you get your website images to display?

Any help is much appreciated.

Kind regards,
Anne


User 2800147 Photo


Registered User
62 posts

This is the code that I used to redirect the images folder. The .htaccess was placed in the images folder

RewriteCond %{REQUEST_URI} !^/[0-9]+\..+\.cpaneldcv$
RewriteCond %{REQUEST_URI} !^/\.well-known/pki-validation/[A-F0-9]{32}\.txt(?:\ Comodo\ DCV)?$
RewriteEngine On
RewriteCond %{SERVER_PORT} 80
RewriteCond %{REQUEST_URI} images
RewriteRule ^(.*)$ https://www.jewelry-tutorials.com/images/$1 [R=301,L]
User 84349 Photo


Registered User
59 posts

Hello Hans & Anne
I'm no expert on this but over the weekend I moved six sites over from http to https. I have read Alter Eagle's explanation and confirm that the .htaccess using Rewiite on is exactly how I did it.

Just a couple of thoughts. If my images were uploaded from an http site not https site I had to reload them from https otherwise its was what seems to be called Mixed and https will not accept it.

Go to your site in a browser and press F12 and then go to Console. If you have got problems that will show you where.

I also had "mixed" put against my stat counter as I had loaded it originally from their http site. I reloaded it from there now https site and all was well.

Hope this helps until AE comes back on line.

Russ
Russ
User 2800147 Photo


Registered User
62 posts

Hello Russ,

Thanks so much. I will try that.

Cheers
Anne

User 187934 Photo


Senior Advisor
18,102 posts

Switch as many images you can to relative linking.
I can't hear what I'm looking at.
It's easy to overlook something you're not looking for.

Here's my S-Drive site with
examples of what can be accomplished in VSD.
http://progrower.coffeecup.com/
Here's my CoffeeCup SCCP Shop with examples of what can be done.
http://progrower.coffeecup.com/shop/
This is a site I built for my work.(RSD)
http://esmansgreenhouse.com
This is a site I built for use in my job.(HTML Editor)
https://pestlogbook.com
This is my personnel site used for testing and as an easy way to share photos.(RLM imported to RSD)
http://ericrohloff.com
http://ericrohloff.com/property/
User 2800147 Photo


Registered User
62 posts

Hello Eric,

Thanks for helping.

I also tried your suggestion to set hot link protection to enabled. Topic link
https://www.coffeecup.com/forums/respon … or-images/

In my case that didn't work.
(After testing I reset the hot link protection and .htaccess back)

In RSD 1.5, using a relative url for images, will not display the image in the program (my images are hosted on server).
With over 1000 images I will get seriously lost if the images aren't displayed when working in RSD.

Is there a way to redirect the /images folder in the .htaccess to https://---.com/images ?

Kind regards,
Anne






Have something to add? We’d love to hear it!
You must have an account to participate. Please Sign In Here, then join the conversation.