NOTE: The DROPDOWN menus with the RSD...

User 2823310 Photo


Registered User
312 posts

If you are using the drop down menu hang in there for a day or 2 before you get the new RSD 2309 update. Typically you all followed the new tutorial "create a new menu from scratch" here: http://www.coffeecup.com/help/articles/ … m-scratch/
That followed a tutorial I did a while ago here on the forum, but with this new build it has to be done differently. I have a repair for the arrows not showing up for the drop downs in horizontal and the drop panel locations.

I also have CSS repairs so you can control the color when the panel is active.
I also have CSS repairs to fix the accordion menu arrows too.

I'll have the step by step tutorial for all of you in the next day or so
If you already updated don't worry you can still fix it later.
I'll let you all know as soon I get it online.

Meanwhile if you can't wait use the button bar menu,
Wayan just did a video on that one too, if you don't like following a step by step.
User 2699991 Photo


Registered User
3,115 posts

Alter Eagle wrote:
If you are using the drop down menu hang in there for a day or 2 before you get the new RSD 2309 update. Typically you all followed the new tutorial "create a new menu from scratch" here: http://www.coffeecup.com/help/articles/ … m-scratch/
That followed a tutorial I did a while ago here on the forum, but with this new build it has to be done differently. I have a repair for the arrows not showing up for the drop downs in horizontal and the drop panel locations.

I also have CSS repairs so you can control the color when the panel is active.
I also have CSS repairs to fix the accordion menu arrows too.

I'll have the step by step tutorial for all of you in the next day or so
If you already updated don't worry you can still fix it later.
I'll let you all know as soon I get it online.

Meanwhile if you can't wait use the button bar menu,
Wayan just did a video on that one too, if you don't like following a step by step.


I have reported the issue with the dropdown arrow not appearing

The Coffee Cup people have fixed it, & hopefully will be in the next upgrade,, so hang on in there a bit longer folks It's on it's way. By the way my video does a dropdown, but not quite the same way as AlterEagle shows you.(Different Designers = Different ways :D

The Help You Need: When You Need It The Most
Website Design & Development
Website Renovations
Wayans' Theme Park
Watch Listen & Learn Video Tutorials
User 2823310 Photo


Registered User
312 posts

Wayan
Thanks for the email on the dropdown arrow, I found that was a missing class (in the coffeecup tutorial) so I don't know how they are going to fix that without messing up the default CSS but here's hoping.

By the way I went and assumed you followed that button bar step by step since it has the same custom classes so my bad one of those dumb moments I have once in a while. Great job on that though too, it's always fun to follow your vids.

Got a new one for you on the dropdown menus, it'd be cool if you can find the time to do that video too for the folks? I bet you can make sense of my mumbo jumbo and make it fun too. My step by step got a bit long covering everything :lol:
User 2699991 Photo


Registered User
3,115 posts

Alter Eagle wrote:
Wayan
Thanks for the email on the dropdown arrow, I found that was a missing class (in the coffeecup tutorial) so I don't know how they are going to fix that without messing up the default CSS but here's hoping.

By the way I went and assumed you followed that button bar step by step since it has the same custom classes so my bad one of those dumb moments I have once in a while. Great job on that though too, it's always fun to follow your vids.

Got a new one for you on the dropdown menus, it'd be cool if you can find the time to do that video too for the folks? I bet you can make sense of my mumbo jumbo and make it fun too. My step by step got a bit long covering everything :lol:

hello AlterEagle
don't know what they did but it works now by just adding the class dropdown to the button and hey presto the arrow shows, but they haven't yet released the update with that in, so hang on in there folks for the next upgrade

The Help You Need: When You Need It The Most
Website Design & Development
Website Renovations
Wayans' Theme Park
Watch Listen & Learn Video Tutorials
User 2823310 Photo


Registered User
312 posts

Wayan, I may be wrong but an RSD update isn't required for that. It's just the tutorial they did on it is missing that dropdown class. The tutorial I just made for it has it and it works fine, basically you just need to add it to the menu container.
User 2699991 Photo


Registered User
3,115 posts

Alter Eagle wrote:
Wayan, I may be wrong but an RSD update isn't required for that. It's just the tutorial they did on it is missing that dropdown class. The tutorial I just made for it has it and it works fine, basically you just need to add it to the menu container.


No AlterEagle, in version 2.4 build 2309, the down arrow for the class dropdown, was invisible that's why I mentioned it to you in case anyone following your or my tutorial would experience the same, No dropdown arrow showing on buttons with that class.it still worked but one couldn't see which button contained a submenu. I made my My dropdown menu, so it needs to be clicked on rather than on on hover.

The Help You Need: When You Need It The Most
Website Design & Development
Website Renovations
Wayans' Theme Park
Watch Listen & Learn Video Tutorials
User 2823310 Photo


Registered User
312 posts

Well maybe I'm confused then.
UL dropdowns and button dropdowns are different.
A working UL dropdown example
A working button dropdown example
Those are done using the existing RSD 2309 build
User 2699991 Photo


Registered User
3,115 posts

Alter Eagle wrote:
Well maybe I'm confused then.
UL dropdowns and button dropdowns are different.
A working UL dropdown example
A working button dropdown example
Those are done using the existing RSD 2309 build


AlterEagle
It's nothing to do with the dropdown panes or anything like that it's to do with the dropdown arrow, that shouild appear when you give a button link the class of "dropdown" it can't be seen (it's there but transparent . That's all, on my demo (not up now as I took it down) I made the dropdown pane only appear when the button was clicked not on hover, as smaller devices don't have hover at the moment.
I was told by a couple of people that when they followed my video, it wasn't the same on their RSD project, because even though they followed the video, the BUTTON-LINK didn't have the ARROW showing. Thats when I realised that anyone using RSD V2.5 build 2309 would have that problem (previous versions are ok). So thats why I informed you just in case other people following your tutorial experienced the same.

link to short video demonstrating the problem with the BUTTON-LINK only (everything else works fine
https://www.dropbox.com/s/jms3h91b2kmt5gi/drop%3Ddowm%3Darrow.wmv?dl=0
Sorry If I confused you into thinking it was the actual dropdown that didn't work

Wayan

The Help You Need: When You Need It The Most
Website Design & Development
Website Renovations
Wayans' Theme Park
Watch Listen & Learn Video Tutorials
User 244626 Photo


Registered User
807 posts

It appears you are both right. I cannot create a button in build 2309 with the dropdown arrow by adding the class dropdown. It does appear to be invisible as Wayan indicates.

I also can view the tutorial example by Alter Eagle and see online it was created by using build 2309 and can clearly see the dropdown arrow on a button with no custom css added.

My only conclusion is build 2309a and 2309b ???

I did try to create a project in a older version and then open it in build 2309 but the arrow becomes invisible. Puzzling...
I don't design the sites, I make them work.
User 244626 Photo


Registered User
807 posts

This appears to be a conflict with the wireframe-theme.min.css ".button.dropdown::after" and the

foundation.min.css ".button.dropdown::after"

Unchecking the wireframe css "border color and border top color" (transparent) in the inspector reinstates the "border-color" of foundation css (which is default #fefefe white)
I don't design the sites, I make them work.

Have something to add? We’d love to hear it!
You must have an account to participate. Please Sign In Here, then join the conversation.