iFrame

User 458539 Photo


Registered User
1,262 posts

Hope you smart guys have a thought on this

https://www.tippingproductions.com/tpc/ … ducts.html

When I preview the page in RSD it works fine. Its an iframe supplied by a manufacturer. The site is far from being finished but need to demo to the client asap.

Anybody know why the contents of the iframe aren't showing? I have done this before and it worked out ok.

Thanks in advance

Byron
User 187934 Photo


Senior Advisor
18,798 posts

Change the iframe src to https.
I can't hear what I'm looking at.
It's easy to overlook something you're not looking for.

Here's my S-Drive site with
examples of what can be accomplished in VSD.
https://progrower.coffeecup.com/
Here's my CoffeeCup SCCP Shop with examples of what can be done.
https://progrower.coffeecup.com/shop/
This is a site I built for my work.(RSD)
http://esmansgreenhouse.com
This is a site I built for use in my job.(HTML Editor)
https://pestlogbook.com
This is my personal site used for testing and as an easy way to share photos.(RLM imported to RSD)
https://ericrohloff.com
User 458539 Photo


Registered User
1,262 posts

Eric

Great idea but it didn't change.

It worked without the "s" and with it when I preview just out of the computer. Not after I ftp it up to the demo site.

I tried jut the iframe code and then I tried what was supplied out of http://embedresponsively.com/.

Thanks - any ideas?

Byron
User 458539 Photo


Registered User
1,262 posts

Sorry - forgot to say that it previews okay out of RSD also

Thanks
User 2792467 Photo


Registered User
136 posts

Erik is right:
The William Hackett website itself is not secure; most browsers won't allow you to call an insecure site from within an iframe. This site may even call and try to load other insecure content as well
you may try it in the iframe sample at W3Schools.com
Eindhoven :: Netherlands

It's easy to see, if you see it.
User 2792467 Photo


Registered User
136 posts

Best solution would be to advise your customer to get a security certificate for their domain. It will also help to get a better Google ranking for their website.
Eindhoven :: Netherlands

It's easy to see, if you see it.
User 2792467 Photo


Registered User
136 posts

Ah, now I see!
Their main website is secure, but the part you are linking to is NOT.
Eindhoven :: Netherlands

It's easy to see, if you see it.
User 458539 Photo


Registered User
1,262 posts


Just to clarify - when I look at the source code and click the link it opens ok. Its only because I'm putting it an iframe that causes it to not open. That would not be compliant with W3Schools.com

Byron
User 2792467 Photo


Registered User
136 posts

Most modern browsers do not allow access to insecure content through iframe. Even if you override settings in your browser to allow mixing insecure and secure content, most visitors won’t.
Google and you may find some tricks, but these usually won’t last.
Anyway, beter not link to insecure content.
Eindhoven :: Netherlands

It's easy to see, if you see it.
User 2868102 Photo


Registered User
7 posts

I uploaded a quick test to my coffeecup site- it loads the iframe source fine. The content loads just fine on that site:
http://rudesyledba.coffeecup.com/iframetest.html

However, when I load it to my personal web server the content does not load: "Mixed Content: The page at '...frametest.html' was loaded over HTTPS, but requested an insecure resource 'http://www.williamhackett.co.uk/product_feed.php?id=369&showcat=1&dep=329&subdep=386&lang='. This request has been blocked; the content must be served over HTTPS."

Have something to add? We’d love to hear it!
You must have an account to participate. Please Sign In Here, then join the conversation.