Component navigation #3

User 458539 Photo


Registered User
1,228 posts

One of these days I'm going to get of my *** and go to 3 but navigation is one of the reasons I have not.

http://tippingproductions.com/tpc/demosite2/

This site all is ok but when you go to mobile with just an icon it doesn't toggle down. You can see the slider acts like it wants to but doesn't. I did change a few things - font &sizes - margins, dropped the one with a border and added a page. But have done this before and its been ok. Now I will admit its happened before and before I just redid the whole thing as it was easier than pestering the forum. But I redid this one and its doing it again. I have compared it to a clean one and it seems identical to me but maybe someone else can see what I did.

Thanks in advance

Byron

PS can you use this component in V3? If so that would make my life easier and would be motivated to switch
User 2699991 Photo


Registered User
2,439 posts

The ID for the menu bar is
topbar-responsive-copy-1"

The hamburger thingy is looking fot the ID

topbar-responsive

so just change the ID for the menu bar to that (can be done at any width)

PS You can use most any component in SD & I have a few menu components available ready-made for SD (which all have the correct ID & Toggle targets :D, & so does Inger on her sharing folder, time to take that leap of faith, no excuses :)
The Help You Need: When You Need It The Most
User 458539 Photo


Registered User
1,228 posts

Wayan

I tried putting that in the ID and it says That ID is already taken: topbar-responsive

Byron
User 122279 Photo


Senior Advisor
12,455 posts
Online Now

You have to change the other way around, the attribute for the hamburger to topbar-responsive-copy-1
Ha en riktig god dag!
Inger, Norway
My new honey site, built with RFF: http://www.eikweb.com/horgenhonning/
Component sharing for RFF, RBB, RSD and SD: http://www.eikweb.com/sharing/


User 458539 Photo


Registered User
1,228 posts

Wayn

I want to make sure I putting it in the right place.

I clicked on the top - it still said column - and placed it in the ID window. Came up with that error. Actually I tried all the things I could click on! All same error code

Byron
User 458539 Photo


Registered User
1,228 posts

I tried every variation individually that I can find and either it doent work or error code
User 2699991 Photo


Registered User
2,439 posts

Byron Tipping wrote:
Wayan

I tried putting that in the ID and it says That ID is already taken: topbar-responsive

Byron

that then means you have 2 menus on the page so as inger says change the hamburger thingy's attribute "Data Toggle" value = top-bar-responsive-copy-1
that's the difficulty by putting a link to a site rather than the project file,, using the inspector to view the code on the site it's easy to miss that there is already something with the ID
The Help You Need: When You Need It The Most
User 458539 Photo


Registered User
1,228 posts

I don't have 2 menus up there. It there a way to completely take things out - to clean it up so I can start again? Have tied to attached the file but it says its not .rsd which it is, so I am typically confused
User 122279 Photo


Senior Advisor
12,455 posts
Online Now

Zip it.
Ha en riktig god dag!
Inger, Norway
My new honey site, built with RFF: http://www.eikweb.com/horgenhonning/
Component sharing for RFF, RBB, RSD and SD: http://www.eikweb.com/sharing/


User 122279 Photo


Senior Advisor
12,455 posts
Online Now

You have the ID topbar-responsive on something in a row-5 It may not be a menu, but the ID has been used. The actual menu has the ID topbar-responsive-copy-2, and that is what the attribute of the icon is looking for.
Ha en riktig god dag!
Inger, Norway
My new honey site, built with RFF: http://www.eikweb.com/horgenhonning/
Component sharing for RFF, RBB, RSD and SD: http://www.eikweb.com/sharing/



Have something to add? We’d love to hear it!
You must have an account to participate. Please Sign In Here, then join the conversation.