Browser compatibility

User 116462 Photo


Registered User
46 posts

Hi again,

I am having some trouble with the Flex layout I use on my site, which is not correctly displayed on Safari. This can be seen here: http://www.artinso.com/orphelion_testing/events.html

Another thing that is a minor annoyance is that design changes that should display only onHover are displayed on Safari even when browsing on a mobile device using the fingers to navigate the pages: http://www.artinso.com/orphelion_testing/members.html

Another problem is displaying the modal window on chrome. Chrome displaces the modal window and keeps it partly off-screen and the content becomes unaccessible. Again this can be seen here clicking on a foto to reveal the modal: http://www.artinso.com/orphelion_testing/members.html

The strange thing is that looking through the web, I found that it seems the flex issues with safari supposedly have been fixed, but I got those error reports from people who claim using the latest Safari version.

Thanks!
Berthold
Berthold, Spain
Astronomy site: http://www.astronomy.artinso.com
Musical events: http://www.orphelion-ensemble.com
RSD 2, RED
User 2699991 Photo


Registered User
1,839 posts
Online Now

Beastro wrote:
Hi again,

I am having some trouble with the Flex layout I use on my site, which is not correctly displayed on Safari. This can be seen here: http://www.artinso.com/orphelion_testing/events.html

Another thing that is a minor annoyance is that design changes that should display only onHover are displayed on Safari even when browsing on a mobile device using the fingers to navigate the pages: http://www.artinso.com/orphelion_testing/members.html

Another problem is displaying the modal window on chrome. Chrome displaces the modal window and keeps it partly off-screen and the content becomes unaccessible. Again this can be seen here clicking on a foto to reveal the modal: http://www.artinso.com/orphelion_testing/members.html

The strange thing is that looking through the web, I found that it seems the flex issues with safari supposedly have been fixed, but I got those error reports from people who claim using the latest Safari version.

Thanks!
Berthold

The modal window display ok for me on chrome
The Help You Need : When You Need It The Most
website https://rsdtutorials.com
new website https://sdv3tutorials.com
components cabinet https://sdv3tutorials.com
hit the components cabinet link

User 122279 Photo


Senior Advisor
11,753 posts

Berthold, what kind of device have you experienced the mentioned Safari problems on? Windows (older version of Safari for Win.), Mac, ipad, iphone?

I have checked your pages in Safari on a Mac, in Ffx on Windows 10 and in Safari on iphone6, and I haven't seen any differences on the events page. Clearly, on the iphone you have all the events positioned in a column.

Regarding the member page I was told some time ago that on-hover doesn't work on mobile devices because they don't have any cursor (mouse). You need to touch the screen with your fingers to make things happen.
Ha en riktig god dag!
Inger, Norway
My new honey site, built with RFF: http://www.horgenhonning.net/
Component sharing for RFF, RBB, RSD and SD: http://www.horgenhonning.net/sharing/


User 116462 Photo


Registered User
46 posts

Hi Inger,
Apparently it was an Iphone with an unknown version of Safari running..
The output he got was the attached image.
Should there be some additional prefixes added to the css? I guess they cannot be added via the head section in RSD, correct?

Thanks
Berthold

Attachments:
Berthold, Spain
Astronomy site: http://www.astronomy.artinso.com
Musical events: http://www.orphelion-ensemble.com
RSD 2, RED
User 116462 Photo


Registered User
46 posts

Wayan Jaya wrote:

The modal window display ok for me on chrome

Hi Wayan,
I attach 2 screenshots. The first is from chrome and the second from FF. The second shows the desired position of the modal.
Apparently chrome moves the modal down to the height of the column that contains the modal. Since the modal is sized 100%, the lower text is cut-off.

Thanks!
Berthold
Berthold, Spain
Astronomy site: http://www.astronomy.artinso.com
Musical events: http://www.orphelion-ensemble.com
RSD 2, RED
User 2699991 Photo


Registered User
1,839 posts
Online Now

Beastro wrote:
Wayan Jaya wrote:

The modal window display ok for me on chrome

Hi Wayan,
I attach 2 screenshots. The first is from chrome and the second from FF. The second shows the desired position of the modal.
Apparently chrome moves the modal down to the height of the column that contains the modal. Since the modal is sized 100%, the lower text is cut-off.

Thanks!
Berthold


Well as I said before It works fine here, on laptop/desktop

I see one small problem at lower devices, (had to borrow a mobile device with chrome installed ) what you need to do is change the modal window back to "FULL" "REVEAL" and unfortunately that means a bit of re-styling to the modal with regard to positioning etc
The Help You Need : When You Need It The Most
website https://rsdtutorials.com
new website https://sdv3tutorials.com
components cabinet https://sdv3tutorials.com
hit the components cabinet link

User 116462 Photo


Registered User
46 posts

Wayan Jaya wrote:


Well as I said before It works fine here, on laptop/desktop

I see one small problem at lower devices, (had to borrow a mobile device with chrome installed ) what you need to do is change the modal window back to "FULL" "REVEAL" and unfortunately that means a bit of re-styling to the modal with regard to positioning etc


Are you referring to removing the additional class I added? I have "FULL" "REVEAL" "CUSTOMCLASS" on the modals in order to style them according to need. (Screenshot attached)
Berthold, Spain
Astronomy site: http://www.astronomy.artinso.com
Musical events: http://www.orphelion-ensemble.com
RSD 2, RED
User 2699991 Photo


Registered User
1,839 posts
Online Now

Beastro wrote:
Wayan Jaya wrote:


Well as I said before It works fine here, on laptop/desktop

I see one small problem at lower devices, (had to borrow a mobile device with chrome installed ) what you need to do is change the modal window back to "FULL" "REVEAL" and unfortunately that means a bit of re-styling to the modal with regard to positioning etc


Are you referring to removing the additional class I added? I have "FULL" "REVEAL" "CUSTOMCLASS" on the modals in order to style them according to need. (Screenshot attached)
The Help You Need : When You Need It The Most
website https://rsdtutorials.com
new website https://sdv3tutorials.com
components cabinet https://sdv3tutorials.com
hit the components cabinet link

User 2699991 Photo


Registered User
1,839 posts
Online Now

No Beastro I was thinking that you maybe just had the class "reveal" as that doesn't scroll if the content of the modal is longer than the height of the device screen,, I have since looked on google chrome on my mobile (samsung) and on a friends tablet (also samsung, also google chrome), and the modal works perfect scrolling and everything,,
The Help You Need : When You Need It The Most
website https://rsdtutorials.com
new website https://sdv3tutorials.com
components cabinet https://sdv3tutorials.com
hit the components cabinet link

User 116462 Photo


Registered User
46 posts

Hi Wayan,

First of all, thanks for all your trouble and help!
That is odd. I must check again on other devices. It might be my phone and not the browser. I also got more feedback from Iphone users and so far only one reported the flex problem. The others had no problems. So maybe I shouldn't worry.
I understand that RSD takes care of all the browser related CSS prefixes to assure compatibility. Is that correct?

Regards
Berthold
Berthold, Spain
Astronomy site: http://www.astronomy.artinso.com
Musical events: http://www.orphelion-ensemble.com
RSD 2, RED

Have something to add? We’d love to hear it!
You must have an account to participate. Please Sign In Here, then join the conversation.