Mobile Menu Width: Not 100% after...

User 2098492 Photo


Registered User
60 posts

Getting myself up to speed with Menu Builder and a prototype project. As you can see in the attached image, the mobile menu width looks correct in the application preview. However, after I export the project, the mobile menu drop-down width is 12%, not 100%. I can futz with the style.css to correct the problem, but I'd rather not. :D

Any suggestions as to what I might be doing wrong in my 500px width settings would be greatly appreciated.
Attachments:
User 10077 Photo


Senior Advisor
1,017 posts
Online Now

It would be helpful if we can see it live. Can you post it online so we can see it in action?
How-To Instructions for Coffeecup Users (tutorials, examples, and downloads)
http://usconsumernet.net/help-for-coffe … -users.php

Personal & Specialized Help for Coffeecup Users
Email me at cchelp@uscni.org or call 865-687-7698
User 2098492 Photo


Registered User
60 posts

I had it working briefly. Now it's really wonky.
http://www.datacad.com/menu_test.html
User 2088758 Photo


Senior Advisor
2,700 posts

It looks like menu_builder.css is empty. I would try re-exporting the code from MB and uploading it to your server again.
Taking over the world one website at a time!

Steve Kolish
www.misterwebguy.com

YouTube Channel:
https://www.youtube.com/channel/UCL8qVv … ttneYaMSJA
User 2098492 Photo


Registered User
60 posts

I seems like the mb file is corrupt. I saved the project under a new name, now this is what it looks like when I re-open it.
Attachments:
User 2098492 Photo


Registered User
60 posts

I can post the mb files if it will help.
User 2088758 Photo


Senior Advisor
2,700 posts

How does it look within MB? Does it appear to be ok?

I have run into this issue before and the only fix for it was to recreate my menu from scratch. Trust me, you may think its a pain in the butt but I worked on this issue with one of my menus for a couple of days trying to figure it out. It only took me 15 minutes to recreate.

Hopefully a lot of these little bugs will be worked out on the next version.
Taking over the world one website at a time!

Steve Kolish
www.misterwebguy.com

YouTube Channel:
https://www.youtube.com/channel/UCL8qVv … ttneYaMSJA
User 2098492 Photo


Registered User
60 posts

I am doing exactly that. ;) This is my first test project so I'm in a position to 'break' it like only a new user can.

Feature Request:
Remember the previous path for 'Export.'

Oddity:
Select File, Save, then choose Export. You are prompted to save the project (again).
User 2098492 Photo


Registered User
60 posts

I've got the test menu recreated as...
http://www.datacad.com/datacad_main.html

So far so good.
User 2088758 Photo


Senior Advisor
2,700 posts

Good to hear! I believe most of these glitches should be addressed in the next update, whenever that is.
Taking over the world one website at a time!

Steve Kolish
www.misterwebguy.com

YouTube Channel:
https://www.youtube.com/channel/UCL8qVv … ttneYaMSJA

Have something to add? We’d love to hear it!
You must have an account to participate. Please Sign In Here, then join the conversation.