Menu Builder does not save settings...

User 863939 Photo

Registered User
11 posts

I have constructed several menus for a website and am getting the hang of MB.

Today I decided to go into one single layer, no subs, menu and change all the buttons to LEFT:ALIGN in the font edit area
instead of align:center. I changed all 3 button divisions, Regular,Hover,Active.
No problem. Save, Export, Update Respective HTML Files, upload files and folders to server , no problem
worked wonderful.
So, I load another menu into MB do the exact same routine, change text to left align, save, export etc.
Nothing changes on website. Go back, load the menu I just exported and half the settings are back to center:align, some are left:align. Weird thing is in MB when it loaded the menu file it displayed correctly as if it changed and remembered all the settings correctly.
So, save everything, reboot computer, just to make sure and try again.

To make a long story short. I did this multiple times, reset alignment, save as I go, save as another file, etc..
Still no change to web page on server after multiple times, I'm now getting agitated.
Finally I went into discovery learning mode, I looked into the style.css file with windows note pad, used find/search and had to manually change all the align:center to align:left by hand. Some were left, some were center,.
Loaded modified style.css file to server and bingo everything is cool, it displayed correctly.

So, why is MB not saving my changes as I work? This wasted a lot of time. I carefully saved my work as I went along.
I even saved as alternate files and then had MB overwrite a previous save just to see if it would ask me if I wanted to do that. I must have changed those alignments in the Font section about 10 times or more.
Now I am not trusting MB to do it's job.

Do you have any similar experiences?
Is there a place MB is caching temp files or something?
Why aren't my saves being saved?
I hope someone can suggest something.
User 863939 Photo

Registered User
11 posts

After some digging I can see where Menu Builder has a ton of stuff in a temp folder under some hidden directory's.
This is in Windows 7, 64bit. I did a screen print , of the directory structure. It is in a .png format so I hope you can see it.
What I noticed was that files in these temp folders are 2 hours older then the file I was working on and and saving.
I compared the creation times and I am wondering if my issues are due to these older files not being cleared out of the temp directory's. I'll attach the screen print. I'm really curious about this. I realize a lot of programs create temp folder but they should go away after closing the program. This may not be happening in Menu Builder.

Well It won't allow me to attach the file because it is too big. None the less I wonder if this is where the problem come fom with MB.
User 187934 Photo

Senior Advisor
19,243 posts

Hi loudorn,
I would try reinstalling. Otherwise a support ticket my be in order.:)
I can't hear what I'm looking at.
It's easy to overlook something you're not looking for.

This is a site I built for my work.(RSD)
This is a site I built for use in my job.(HTML Editor)
This is my personal site used for testing and as an easy way to share photos.(RLM imported to RSD)
User 863939 Photo

Registered User
11 posts

Ok, I resized the file. Hopefully you can see the windows file folder structure at the top of the jpg.
It shows how I drilled into the hidden appdata folder to find where MB places all this.

Even if I reinstall, MB will recreate this as this is part of it's default design I imagine and is not selectable during installation.
I hope you can see the jpg file ok.
This may or may not help someone else.
User 187934 Photo

Senior Advisor
19,243 posts

I would open a support topic. The cc Gurus may have an idea of what's causing your issue. It may be a corrupt windows file.
I can't hear what I'm looking at.
It's easy to overlook something you're not looking for.

This is a site I built for my work.(RSD)
This is a site I built for use in my job.(HTML Editor)
This is my personal site used for testing and as an easy way to share photos.(RLM imported to RSD)
User 2345467 Photo

Registered User
1 post

I'm having the exact same problem. I've been building a new site with HTML editor and MB and was having no problems modifying a menu in MB and exporting the changes to Editor. Then yesterday I started having the exact same issues as Loudorn. Have you opened a support topic?
User 863939 Photo

Registered User
11 posts

Yes I opened a support ticket.
Scott replied to me and didn't have a direct solution. This was the first time they had heard of this he said.
I was given access to a beta build of MB but I can't share that, support would have to offer that through a support ticket I assume.

I did a clean install last night and will try again later today. Very frustrating scenario when you are trying to get work done, thinking you are doing everything correct and then no results. Very weird for sure.
If I experience anything new I'll share here.
Lou D.
User 863939 Photo

Registered User
11 posts

I'll keep this short.
I uninstalled MB, cleaned out any left over directories and files.
I did a fresh install of my software not the beta version.
I got half way through editing another menu and soon the save file selection was grayed out and shouldn't be.
When i would choose a new menu selection and go to edit Regular,Hover,Active areas sometimes I had to check the font area to make it available sometimes one was grey and another was checked and available.
So I saved as a different file/version. Edited some more and went on like that.
Somewhere along the way the software is getting confused and inconsistent in it's function.
At least when I was done I managed to export and upload to server and it did make the changes.
Something is hinky with this though.
I guess I can uninstall and load the beta in and test that.
I'll post back with what I see.

As a note. I run CCleaner program and I added a custom setting for it to go and clean the Program Files/appdata/tmp/menubuilder folder after I close the menu builder program. That way all the remnants get cleaned out instead of hanging there.
User 2088758 Photo

Senior Advisor
2,836 posts

Hi Loudorn,

I have never experienced any issues like this and I have been using the menu builder for a long time now. I'm thinking it has to do with your system and not the app itself.

A quick suggestion. Try saving your MB to a file location of your choice instead of selecting the default one. Another thing, are you running this application as administrator? Sometimes this fixes random issues with MB or any CC app.

You do this by location your .exe file for menu builder and right-click on it and run as administrator, put the check mark in the "Always" box.
Taking over the world one website at a time!

Steve Kolish

YouTube Channel: … ttneYaMSJA
User 863939 Photo

Registered User
11 posts

Hello Steve,
Yes, I run my apps as administrator.
This is the only app on my computer having issues that I am aware of at the moment.
I have been working on computers since my Zenith Z-100 days which ran DOS AND CPM, before msdos existed.
Kind of dates me eh!
It doesn't make me an expert but I know my way around the OS and hardware fairly well.
I build all my own computers.
I bought my first Coffee Cup software back in 2001. The Big Cup :-)

Web design and construction, blah!, FAIL.. but I try :-)

I will try your suggestion in regards to the directory where the saved files are placed..
How ever when I am in the program, making edits and go to save those changes and then the save selection is grayed out that is very unusal.
At the same time I am concurrently running CC HTML Editor, Filezilla for uploading to the server, and Gimp my graphics program and they all behave well. I'll continue to make one step changes so I can try and find the culprit issue.
I also monitor my hard drive activity to make sure the writes are taking place when I click save.
Very well could be some kind of system issue. I'll run my hard drive diagnostics tools and do some system checks just to make sure.

Have something to add? We’d love to hear it!
You must have an account to participate. Please Sign In Here, then join the conversation.