horizontal menu problem

User 2140875 Photo


Registered User
291 posts

I have a site developed in VSD. The page width is 850px. In MB I want to create a horizontal menu with 7 buttons across.

I remove the "auto" width check, set the max width to 848px. Add 7 horizontal buttons. When I preview the last button wraps to a second line. I've tried adjusting the individual widths of each button, played with the width of the menu, but cannot get that last menu item to stop wrapping.

Have attached screen shot from MB and from the preview screen.

Any help would be appreciated.
Attachments:
User 187934 Photo


Senior Advisor
18,152 posts
Online Now

Take a look at the padding and or margin.
I can't hear what I'm looking at.
It's easy to overlook something you're not looking for.

Here's my S-Drive site with
examples of what can be accomplished in VSD.
http://progrower.coffeecup.com/
Here's my CoffeeCup SCCP Shop with examples of what can be done.
http://progrower.coffeecup.com/shop/
This is a site I built for my work.(RSD)
http://esmansgreenhouse.com
This is a site I built for use in my job.(HTML Editor)
https://pestlogbook.com
This is my personnel site used for testing and as an easy way to share photos.(RLM imported to RSD)
http://ericrohloff.com
http://ericrohloff.com/property/
User 2140875 Photo


Registered User
291 posts

Eric,
Padding is at 0, margins either auto or manual set to 0. Still same problem.

I know I must be doing something wrong, just cannot figure out what it is.
User 2140875 Photo


Registered User
291 posts

Solved problem. Had to go to design pane, make each button real small, add the extra button, and then gradually increase the size of each button. I am sure that's not the way it is supposed to work, but at least the problem is solved. Thanks.

Have something to add? We’d love to hear it!
You must have an account to participate. Please Sign In Here, then join the conversation.