Mp3 flash player


Registered User
3 posts

Okay so I have the registered version. I formatted it and everything then when it played i got a "this player was created by coffee cup go to coffee cup to buy the registered version" message. It isn't up on my site because it was auto play and was annoying to have that message keep looping.


<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000"
codebase="http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=8,0,0,0"
width="288" height="200" id="CoffeeCup" align="middle">
<param name="movie" value="http://www.kwalshdesigns.com/freedomjukebox/freedomjukebox.swf"/>
<param name="quality" value="high" />
<param name="scale" value="noscale" />
<param name="salign" value="lt" />
<param name="bgcolor" value="#ffffff" />
<embed src="http://www.kwalshdesigns.com/freedomjukebox/freedomjukebox.swf" quality="high" bgcolor="#ffffff" width="288" height="200"
name="CoffeeCup" scale="noscale" salign="lt" align="middle" type="application/x-shockwave-flash"
pluginspage="http://www.macromedia.com/go/getflashplayer" /></object>



Thats the code i have on my page. The freedomjukebox is in the same folder as the button images and music. Am I missing something?


Ambassador
3,120 posts

I'm pretty sure if the html file loading the .swf is not located in the same folder, you have to manually edit all links (jpg & mp3) in the xml file to full paths in order for it to play correctly. It's easiest and best to simply keep the "freedomjukebox" folder and the html/swf/xml relative as to how the project was saved. :|


Registered User
3 posts

The .swf .xml and .html are in my public html area with the freedomjukebox_files folder placed in the same area. Does that make sense? The page the jukebox is on is in my public html folder as well. So I am not sure why that would be the issue. It sounds great when I preview it in the jukebox program just seems to not be getting on the web easily.


Registered User
3 posts

I figured it out, Thanks anyway!


Ambassador
3,120 posts

Well, just to say I'm not crazy, the initial post showed a path of
<embed src="http://www.kwalshdesigns.com/freedomjukebox/freedomjukebox.swf",
which isn't the root folder. That's why I was saying to keep it all together. Anyway, glad you got it working, that's what matters. ;)

Have something to add? We’d love to hear it!
You must have an account to participate. Please Sign In Here, then join the conversation.