Broken Pictures....


Registered User
15 posts

I uploaded my website the other day. Everything went fine.
I saved my files on a portable hard drive. So when i went to my other computer, I made some changes and uploaded it...this time i got broken pictures. But the text I changed was changed.

So I deleted the site, and uploaded it again. This time some pictures showed up, but not all.

www.unleashedsoftball.com

I use Godaddy hosting...and sent the files through VSD.

Thoughts??


Senior Advisor
8,739 posts

Porting a VSD project to another computer can be quite a chance. You need to have exactly the same file structure on both computers for it to work. I'm not sure if the drive letter also has to be the same.

I'm not a VSD user, so someone more knowledgeable will have to chime in and explain what went wrong with your images.


Registered User
15 posts

Yea i always saved all the files to the portable drive....the drive letter may have been different, don't recall.

But even now, i deleted everything and started over, and it still doesn't work.


Senior Advisor
12,219 posts
Online Now

When you say deleted everything, does that mean you used an external ftp program or your host cpanel to delete the files?
I can't hear what I'm looking at.
It's easy to overlook something you're not looking for.

Here's my S-Drive site with
examples of what can be accomplished in VSD.
http://progrower.coffeecup.com/
Here's my CoffeeCup SCCP Shop with examples of what can be done.
http://progrower.coffeecup.com/shop/


Registered User
15 posts

i went into go daddy control panel, and deleted the files.


Senior Advisor
12,219 posts
Online Now

I checked your site. Have you tried re-syncing your site?
I can't hear what I'm looking at.
It's easy to overlook something you're not looking for.

Here's my S-Drive site with
examples of what can be accomplished in VSD.
http://progrower.coffeecup.com/
Here's my CoffeeCup SCCP Shop with examples of what can be done.
http://progrower.coffeecup.com/shop/


Senior Advisor
1,625 posts

It looks like the problem is some of the images are not loaded to the server. When I view the source code and try to view the pictures they spit out a 404 error.

"Not Found The requested URL /files/IMG_0.jpg was not found on this server. Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request."

Check your server and make sure the files are uploaded, if they are not, simply upload them and that should fix your problem...

However, if they are uploaded, then check the file names and make sure they match the file names on the server... Because the 404 says they are not there...

Hope this helps...
"An Apple doth not fall far from its tree, yet an orange does."

http://lbwebsites.com - Web-Design & Hosting.
http://helpsite.sirage.com - HTML5, CSS3 and CC Help Video Blog.
http://www.sirage.com - Personal Site.
http://www.aveofluv.com - Wedding Site.


Ambassador
2,150 posts

I am hoping Eric or someone will confirm this, but in the earlier versions of VSD a copy of the images was NOT stored so every upload relied on pictures in external folders

VSD version 7 at least now stores all its own pictures in its own folder so transferring from one pc to another also keeps the pictures in the correct folder.

I would be tempted to do a SAVE AS (new website name) and then upload to a new folder on the server yoursite.com/testsite2 and see if it all works there.

That at least would clear up whether images are missing or not
Started using CC VSD in January 2009, I don't do HTML code, sales exceeding £100,000 from my SCCP & SCDP shop to date, Enjoying semi-retirement
Hosted FREE on CC S DRIVE www.chauffeurdrivenluxurycars.co.uk
My new VSD & SCCP site Oct 2011 www.deloreanjewellery.co.uk
My friendly window cleaner www.mwcwindowcleaner.co.uk


Ambassador
2,794 posts

I would create a folder for all images used on the site. Load your images from this folder, and make sure the folder "travels" to any other computers you have VSD on so it can find the images.

The images you see in VSD's Files folder are basically "snapshots" of the graphic items on your pages.
I would think you still need your original image files saved along with your site.

I've never had any problems moving my sites around, I've copied sites to other computers by way of a jump drive. But I have all my site files in one main folder (including my images folder) that doesn't change, so it's set up the same as the original site no matter where it goes.

You may have to go back to where ever your images are and copy them then make a folder for them on the other computer and re-load them from it.

I love deadlines. I like the whooshing sound they make as they fly by. (Douglas Adams)
http://www.callendales.com

Have something to add? We’d love to hear it!
You must have an account to participate. Please Sign In Here, then join the conversation.